ViewCaptureToFile command won't save and crashes

I am an architecture student using an evaluation version of Rhino 6 for mac - my computer is fully updated 2018 Macbook Pro i7 top spec everything else.

I have been using it without any problems using this license key for about 2 weeks, though today I have tried to used the ViewCaptureToFile command in raytraced mode though now I am able to choose the ViewCaptureToFile options however when click “save” to save the file, the folder and files above whites out and I am unable to cancel. After a while they reappear and I am able to click save again but then the problem continues and all I can do is force quit.

When reopening Rhino starts without the “rhinoceros quit unexpectedly” alert

Would anyone have any ideas what might be going wrong?

Thanks, George

@17george

I am unable to follow your instructions and unable to repeat the problem running V6 SR26.

Are you still able to repeat this?
If so, please detail out the specific steps to follow to duplicate the problem.

Thanks

Hi John, thanks for taking a look.

I have the view as raytraced, then I enter Viewcapturetofile, the “view capture settings” dialogue box opens and I am able to change settings and can click apply. This then leads to the “save” dialogue box, though when I click “save” this leads to the program getting stuck. Usually you can see folders and files to select the location of the save, though when I click “save”, this goes grey like the rest of the dialogue box and does not save. If I leave it for some time then the folders and files reappear, and I can click the buttons again, though if I were to also click “cancel” the same problem happens as with clicking “save” and so I have to force quit. If I change programs and then come back to rhino, this also refreshes the “save” dialogue box but again it will not save.

I have tried using several different files and the problem persists so I don’t think it is anything to do with the file itself.

I followed your instructions, and when I click Save, then I see a rendering progress bar in the left panel as the rendering progresses to the specified number of passes. This can take some time and my MBP’s fan comes on.

Is it possible you just aren’t waiting for the rendering passes to complete?


It has worked fine in the past as shown in your screen capture, the problem is that I am unable to save the image so that the rendering process can begin. It’s stuck at the save point as in the screen capture in my previous post and after that the fan is coming on as well but will not go any further.

I think the settings are saved in your Rhino Preferences file.
If it were me, I’d reset the PREF list and see if that sorts it.
https://wiki.mcneel.com/rhino/mac/resetprefs

Any luck?

Thanks John, that seems to have sorted everything - really appreciate it!