ViewCaptureToFile command issues

Hello,

I have been using Rhino6 since June, despite the fact that it crashes quite often, I like using the software. Recently, I wanted to save a viewport as pdf but the software crashed instantly before generating the pdf, I then tried the capture file option and saved as a jpeg file. When I viewed the jpeg I saw just a black screen. I followed instructions on reseting preferences for rhino and tried to capture file again, but nothing changed.

Can someone help explain what I am doing wrong please?

Thanks,
Nesrin

Hi Nesrin -

It doesn’t sound like you are doing anything wrong, but it is possible that your hardware is not supported. Could you please run the Rhino SystemInfo command and copy-paste the result here?
-wim

Hello, here is the result:

Rhino 6 SR31 2020-11-10 (Public Build, 6.31.20315.17002, Git hash:master @ ff08c426b1ef7d3a1c50a01e5e87220a68a9f815)
License type: Educational, build 2020-11-10
License details: Cloud Zoo. In use by: n.kianni0220161 ()

Apple Intel 64-bit macOS Version 10.15.7 (Build 19H2) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,4
Machine name: Nesrin’s MacBook Pro
Language: en-GB (MacOS default)

Intel Iris Pro OpenGL Engine (OpenGL ver:4.1 INTEL-14.7.8)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel Iris Pro
Displays: Color LCD (221dpi 2x)

Graphics processors
Intel Iris Pro (1536 MB)
Color LCD (1440 x 900)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Broadcom Corp.: Bluetooth USB Host Controller

Bluetooth devices
Broadcom: Magic Mouse 2

Third party kernel extensions
None

Third party plugins
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftCryptoTokenKit.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros 2.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.31.20315.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.31.20315.17002
/Applications/Rhinoceros 2.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 6.31.20315.1002
/Applications/Rhinoceros 2.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.31.20315.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.31.20315.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.31.20315.17002
/Applications/Rhinoceros 2.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.31.20315.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.31.20315.17002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.31.20315.17002
/Applications/Rhinoceros 2.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.31.20315.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.31.20315.17002