ViewCaptureToFile clarity problems


#1

In Rhino5 when saving out as a high rez (8025 x 3865) Jpeg the lines come out grey not black. We’re trying to get a good clean hi rez output to use as artwork in an owners manual of a product. We’d like some Top viewport and Perspective view captures.

I’ve also tried simply printing the viewport as a PDF, but not happy with those results either.

I’ve got the anti aliasing set to X8 in the View Menu in the Options. I’m looking at using the Pen and Artistic renders.

What about some of the settings in the View Display settings in terms of Line Widths? Would that help?

Any suggestions would be much appreciated.


#2

Yes, every even number will give me sharp curve edges, 2, 4, 6 etc pixel line width are the best here. But this might be different from nVidia to AMD and Intel, as the drivers handles the AA, so run som tests.

Just make a copy of the display mode you like, name it “Wireframe_ViewCapture” or something, adjust the settings for the different object types and -ViewCapture away :smile:

Then you can make a makro to change display mode, viewcapture at desired resolution and change display mode back again.

Good luck!


#3

Gray lines are pretty much what to expect with line widths of less than 2 pixels and antialiasing. When you draw a 1px line, the simplest way is to just fill the pixels, that intersect with the line. But that will give a very jagged appearance to angled lines. You can imagine antialiasing as “spreading” the amount of “ink” to the closest pixels to the lines mathematical position. So having a one pixel line running right between two rows of pixels will end up with two rows getting 50% gray each, which looked at from afar gives the impression of a very faint, smooth 1px line. It’s very unlikely that lines will align to pixels to more often than not you will have gray 2px lines.

If I may suggest Make2D as an option. Vector lines have the advantage of being resolution independent and you can set line widths according to meaningful values in print such as pt or mm.