View modes suffer many inconsistencies

unhandled

#1

View modes suffer many inconsistencies.

  1. the sun for some reason is set to night time I don’t know what region but it looks like northern Russia. Sun should be on manually as a default not to some random location.
  2. If one has “use advanced GPU lighting” checked the shininess of an object is totally gone.
  3. If one doesn’t have “use advanced GPU lighting” checked and doesn’t realize the sun is set to night, turning the sun on turns all objects black in the viewport.
  4. Raytraced mode renders curves even though in the render tab those areas are not checked, funny thing is one can turn on and off the sun and skylight there but the curve render area there has nothing checked but the curves still render in the viewport.
    RM

(Nathan 'jesterKing' Letwory) #2

I think @pascal already reported something like this to the bug tracker.


(Pascal Golay) #3

The thing that I see is that with a non-default material applied, non-selected objects show internal wires when an object is selected.

https://mcneel.myjetbrains.com/youtrack/issue/RH-41098

I do not see curves drawing if curves are not checked in the Display panel.

-Pascal