View capture

If I use view capture to save the view the colors come out all wrong. Screen shots work just fine. This works fine on the PC.

Can you please send detailed instructions for repeating this - perhaps attach a sample file where this is happening? I’d like to try to reproduce this on our computers.

It seems like it’s caused by a custom display mode. I tried to export the display mode but the option if greyed out. It’s easy to recreate. I duplicated the rendered display mode and changed the background color to white and turned off the grid. Whenever I try to view capture using this display mode the colors are shifted. Im running rhino 5.0.2 on OSX 10.9.5

Example.3dm (837.0 KB)

that’s odd… if i try doing what you’ve said, the colors are correct

i’m on rhino 5.0.2 & osx 10.10.5

Maybe it’s an issue with 10.9. I seem to remember hearing there was a render bug with this version of the OS. unfortunately I can’t get IT to update me to test that theory.

This very well could be a Mavericks/Rhino issue.

@mary, using the file that @okeating posted above, can you reproduce this issue on Mavericks?

@dan Work on 10.9.5. I tried it and I do not think there are problems.

Guess I’m just unlucky

are you sure the default rendering mode hasn’t been altered prior to you changing the colors and grid?

if you go Rhino-> Preferences-> Display Modes
under ‘Standard’ select Rendered
click the gear icon at the bottom of the panel
click Revert to default values.

then try it again…
same thing?

Fun model!
I am unable to reproduce it here at McNeel with the instructions that were included.
Sorry to say, it is working for me and I have Mavericks, too.
Anything else I may be missing?

  1. Turn grid off.
  2. Change Rendered Display mode to solid white
  3. Make display mode active.
  4. Use ViewCaptureToFile.

Maybe I forgot some detail…
Thanks for your help.

Mary Ann Fugier

So I dug into this a little more. It looks like the bug is tied to the grid settings. If I create a new display mode based on the rendered mode and change the background color to white I get this.

If i change the grid settings I get this.

I appreciate you guys taking the time to look into it. Fortunately this is an issue with an easy workaround since I can just take screen shots.