View capture to file creates clipping plane that isn't there

if you set the scale to 1 and use viewport resolution does it help?

1 Like

Yes it works fine then. But I need to be able to do it at higher resolutions.

ok, if you set it to viewport resolution and scale to 2 does it still clip?

if so, set it back to one and enter the resolution in the custom slot-

multiply your screen rez by 2 and enter it manually… does it work?

just noticed you are miles from the origin… if you center it around 0,0,0 does it improve?

I moved it to 0,0,0 and still in both cases at a custom typed in resolution and just at a viewport resolution scale 2 I have the clipping. Each of the images are labeled for the settings I used.

if you show the camera and adjust it a bit to have the camera focal point be farther out of the scene does it help?

It does not - and I just downloaded the rhino 7 eval and tried it there.

anything strange about your set up, 2nd monitor, laptop plugged into a port replicator or display dock, multiple graphics cards, etc?

I’m so intrigued Kyle that it is working for you just fine! Feels like I’m fighting a gremlin here.

I do have a second monitor, no port replicator or display dock. Cards below:


I sent the file to a coworker, they had the same issue as me with it clipping.

I’ve even gone through and purged blocks, purged in general, inserted it at 0,0,0 all in rhino 7.

Hi -

I can’t reproduce the issue here but when I open your file, I am greeted by these two dialog boxes:


Since none of us can reproduce the issue with your file, I suppose that one of those might have something to do with that - most likely the missing block.

At any rate, the issue that John referred to earlier (RH-61061 ) was about tiling when capturing to a larger size than the screen, not for the issue with the view being clipped.

The clipping issue is still open on our list as RH-56182 and I’ve added this thread to that report.

Thank you Wim, i’ll keep checking in. Really appreciate all three of you taking a look at this! Thank you for the support.

just to pull the wildest of hairs…

can you unplug your second monitor and just run on the default monitor… does it still happen?

if so-

follow these steps in this thread to insure rhino is in fact running on your quadro-

Hey Kyle,

I unplugged the monitor, restarted, and i’m still getting the same issue. It even happens when I make a new file from scratch with just plain solids and some simple closed polysurface lofts.

Seems to act up quite a bit when I introduce a plane or box as the ground level, and when I get the camera close to objects. Always looks perfectly fine when I do a scale 1 viewport resolution viewcapturetofile though!

I also checked on the video cards - it’s already set to run high performance and I changed the OpenGL rendering GPU to be the quadro card and power management mode to prefer max performance. Still running into the clipping.

I’ve done it in both r6 sr31 and r7 eval with most current. I’m curious if anyone else is having this issue still since there were a few other above.

Appreciate you checking in.

beats head on table <<<

ok, call us on tech and lets do a remote session to see if we can see anything we are missing.

call when you have a bit of time where we can remote in and mess with stuff, ie mid day and out of sight of any pressing deadlines.

Hey Kyle - can you point me to where I call you on tech? This is a first for me. Would absolutely love to do a remote session and see if we can clear it up.

The good news - I opened rhino 7 eval up halfway through today and it asked me to update the eval. It’s showing this now:
(7.1.20314.23101, 11/9/2020)

And, my file in r7 is NO LONGER doing the clipping. :star_struck:I tried it in r6 - still happening. :face_with_thermometer: So if we do a remote session it seems like the issue is now just happening for me in r6.

call our tech support at (206) 545-6877

Doaa is on today (11-13-2020) and she can help you-

1 Like

Was having the same issue in Rhino 6 V 6.32 taking an interior perspective for an architectural project I am working on. One corner of the building was on the origin point. units were in feet.

Opened it up in Rhino 7 and it worked fine

Rhino 6

Rhino 7

in v6, go to 4 view layout, click in your perspective view, then hit f6 to show your camera in the other views. Please post a screenshot of that-

Hi, I had never had this issue before, and suddenly within the past month, it decided to start giving me issues. On a whim, I decided to make the tolerance .000001 to see what happened and it wasn’t an issue anymore. This could have been a fluke and there might be a more deep-seated issue, but it is worth a shot. Hope this helps!

In my case the clipping was caused bcs of changing ZoomLens value. Reseting to default solved the issue.