Video card again - Quadro disaster


#1

Hi,

extracted from this thread:

Quadro 4000 approx. 1s
Quadro 4000 (Helvetosaur) approx. 0.6s
Quadro K2000 (Jeff) approx. 0.8s
Quadro K5200 (Jeff) approx. 0.5s
Quadro K2000 (BrianM) apporx. 4s
Quadro K4000 approx. 1.8s
Quadro K1000M approx. 1s
Quadro FX2800 approx. 1s
Quadro 6000 (Micha) approx. 2.6s
Quadro 6000 (Michael VS) approx. 1.8s

After there is found a trick to get GTX cards running much faster I would like to bring the discussion to the so much different results within the Quadro cards.

I ask me, why are the K2000 speeds so different and why is my Quadro 6000 so slow? The Quadro cards should be without Nvidia OpenGL software limit, so why is a newer Quadro 6000 slower than a Quadro 4000? And why we get so different results? The same card type can be 3 times slower depending on … ? At Jeffs computer can be seen extreme good results. There seems to be an important difference, but what is it?
I suppose so all Quadro cards are able to get times below 1s, but how? If a Quadro 4000 can get 0.6s why not a Quadro 6000?


(Menno Deij - van Rijswijk) #2

I don’t think you can compare these results without keeping the OpenGL settings exactly the same and running the same driver version and making sure that the viewport size is the same.


#3

I tried to get the max speed of the Quadro 6000 and tried anything - different viewport sizes, disabling any quality feature … the speed results are quite stable, I don’t get more than 2.5s. Also I tried different driver, installed the latest one. No better results. So, the speed results are quite independent from the Rhino setup.

Also it’s not really a comparing, more a looking for the difference. Why are some machines so much faster?

I tried to avoid the influence of installed plugins and tried a test in save mode, but in safe mode the shaded view isn’t available. Is it right?


#4

Have you tried to reinstall Rhino? I did a clean uninstall and reinstall to get rid of all WIP stuff from my machine and that sped things up quite a bit. My Quadro has been rock solid since, and your 6000 IS faster, so if it isn’t it is neither the card not Rhinos fault.
Getting a new HDD and starting from scratch can be the fastest path to success, so consider that too.

-Jørgen


#5

Hey Micha,
I just realized I didn’t use the “Workstation” setting, but the “3D App - Defautl Global Settings” and that is faster. I I use the Workstation setting I get 2.3 seconds, and with 3D App I get 0.8 sec.

Test it out:


#6

WOW!! Thats An Amazing Difference on My Quadro6000 too. This could be the key to everyone’s quadro issues!

Quadro Nvidia Settings:
Quadro Driver Version: 340.66 OEM Driver (Advice - Do Not use the Performance Driver)
3D App - Default Global Settings
Power Management Mode: Prefer maximum performance

My time went from 2.17sec to 0.67sec for the same 100 frame rotation of the 5x5x4 spheres.
Amazing improvement…
Whats also interesting is that if I duplicate the sphere array 4 x times and test again, the time has dropped from 8seconds down to 2.1 seconds, and monitoring the GPU the load level whilst running the test has dropped from 75% to 30%. So it is running 4 x faster with the above setting but GPU is running at less than half the load of the 1st test. Anyone else see this.?
Thanks. Michael VS


#7

@Michael VS: Here I see a more logical result, GPU usage 86% (2s) instead 33% (18s).

OK, the first problem is solved. Next one - the bike model. For me this is the best test ever, the display is slow and it’s needed to be faster. Not like the repeated object tests this one is like an example from the real usage - medium file size, medium complex model, lazy display.
www.simulacrum.de/download/Testmaxspeed001.rar

I disabled advanced lighting and shadows, light mode “default”. testmaxspeed -> 19.6s (Quadro 6000). (the first run is slower most, best try a few runs). So far I know Quadro 4000 cards get approx. 15s and my old GTX285 was around 20s. Could be great if we could test several Quadro cards on this model. My Quadro 6000 is fast like an old GTX285, also with the new Nvidia global setup “3D App …”.
So, the question is - is there a setup that brings more speed and if yes, why?

(My old GTX285 results was for full NURBS/curves 20s, no curves 8s and only meshes 4s (extract rendermesh and hide NURBS. )

@Holo: if the results of the bike tests show me that my Quadro 6000 is slower than from other user, than it’s time to try a fresh install. Thanks for the hint.

PS: The bike example isn’t the worst case. My worst real project model (a train) works with approx. 1 fps.


#8

Hi Micha, I was the one who converted the SW bike to Rhino and made the rhino file, so I tested that one here, and with the Holomark Render Speed display mode I get 4 seconds for a maximized Testmaxspeed 8x AA.
That is with the nurbs model, not extracted rendermesh. I am downloading your version now to see if there are any differences.

Edit: With your file I get 5.55 seconds in rendered mode with shadows off and advanced GPU ligting turned off. I resat the mode and only turned those two things off. And I get the same speed if I maximize the view, so the card has not reached it’s limits.

Edit 2:
Default Shaded mode, maximized view (1920x1200) at 8x AA = 25.4 sec.

  • Turned off isocurves and edges = 5.34 sec
  • Renderingmaterial instead of custom material = 4.21 sec
  • Default lighting = 4.17 sec
  • Extract rendermesh and hide objects = 2.54 sec.

Default shaded with meshwires turned off and extracted rendermesh = 2.9 sec
With meshwires ON = 4.63 seconds.
(This to me indicates that Rhino should be able to draw curves MUCH MUCH faster if it converted them to “mesh wires”.
It would not be accurate, but it would be fast.

Culling backfaces makes no difference.

-Jørgen


#9

Hello @Micha and @Holo. I can confirm on My Quadro6000 (i7-3770 cpu) that this Bicycle model is not stressing the GPU or CPU at all, and there is actually another bottleneck somewhere. Only with the rendermesh test did my GPU run up to 80%. With the other Nurbs tests the GPU maxed out at 12% and the CPU was at max of about 40%(On 1 of the CPU cores).
Shaded mode: 20sec
Shaded Mode with all Isocurves ticked off: 11.2sec
Rendermesh Only test: 3.5sec
Rendermesh Only @1920x1080: 3.5sec


(Mikolaj Jarski) #10

I know it’s a Quadro topic but my results on gtx660, 8x AA, GeForceTestEngine are similar (bike model):
default shaded: 16.92 sec
no isocurves: 12.67
no isocurves, no edges: 7.67


#11

@Holo: OK, so your standard shaded is a little bit slower than my Quadro 6000. You tested a Quadro 4000? Your speed mode is a mode without curves, right? Is the display mode part of Holomark 2?

@Mikolaj: It interesting to see GTX cards in comparsion to Quadro cards, since Quadro cards are sold as special CAD cards.

But yet all shaded mode tests at approx. the level of the old GTX285. Looks like there is no surprise possible.


#12

As I am speccing a new box for my cad work, this topic is of great interest. I post this (for a giggle) with my current specs ->

  • Graphics Card = GeForce 8800 GT - 512mb vram - 314.22 driver
  • CPU = Core 2 Duo E8400 @ 3.00 ghz - 8.00 gb ram
  • OS = Win 7 x64 sp1 - Rhino 5 x64 sr9

Testmaxspeed with the bike model

Shaded Mode
as loaded = 31.34
GeForce enabled = 29.69

Rendered Mode
-no curves - default lighting - GPU lighting = off
as loaded = 10.89
GeForce enabled = 11.75

Default Shaded mode, maximized view (1600x1019) at 8x AA = 29.70 sec.

  • Turned off isocurves and edges = 12.31 sec
  • Renderingmaterial instead of custom material = 10.81 sec
  • Default lighting = 10.9 sec (lighting seems to have little effect)
  • Extract rendermesh and hide objects = 5.60 sec.

Rendered Mode
Per last above = 5.49
GeForce enabled = 7.63


Quadro drivers updated - Good news
#13

8800Gt was a good card. So good that Nvidia re-labelled it and sold it as the 9800 and then again as the GTS250.