Very slow rendering, orbiting, zooming, un-do, etc


Myself and my colleagues have been having some difficulty with Rhino behaving very slowly when working on projects larger than 20 or 30 MB’s, most times no larger than 600-700 MB, though we’ve also been having issues with completely new template files. Things such as changing a layer name, re-arranging material order, or turning on off layers takes a matter of 15-20 seconds sometimes, but it seems like it shouldn’t be like that on an empty, or small, project? Even using control-Z to undo a step can result in the session freezing and crashing.

We’re all running computers with the following specs, or higher:

Interl® Xeon® Silver 4108 CPU @ 1.80 GHz (Dual processors, 32 core total)
Quadro P4000 cards

We all use Flamingo to render, I’d try disabling that plug-in but I can’t seem to disable anything at all in Rhino, clicking the little check box in my plugin window to try to un-tick it doesn’t do anything. That said, there’s a few settings that can’t be changed right now. No matter what settings we try to set for our renders, such as resolution, quality, size, etc, nothing happens. It always defaults to the viewport, low quality, and 72 dpi, every single time. I’m sure this is a separate issue, but thought it worth mentioning.

Anyone have any ideas on what to do? Seems to me (though I’m no expert at all in PC’s) that our computers should really be able to handle these projects. They are not what I’d consider complex in any way, and are often no larger than a small shed in size.

EDIT: Just a few more notes, probably worth knowing:

  • We are often in wireframe mode, not shaded or rendered.
  • Orbiting in wireframe, or even changing from a front to a side view takes a good long while.
  • When rendering in Flamingo, each pass can take upwards of 4 - 5 minutes, again, with projects containing maybe eight or nine textures, no background, no lights, nothing that would seem to me to make it a complex render, and as mentioned above, all at very low quality and low resolution.
  • None of us work with multiple programs or Rhino sessions open.

EDIT 2: Just wanted to add this - I’ve just pulled one of the problematic files onto my personal computer, and opened it up - runs incredibly smooth, no lag in commands or orbiting or anything. The only difference between the work computer and my personal computer is that it’s A) just the 90 day evaluation software and B) no Flamingo. Is it possible that Flamingo is what is causing all these issues? My personal PC runs with 16gb RAM and a RTX 2070, shouldn’t my work station be blowing that out of the water though?

Well actually, no. A ton of very slow cores is fine for software rendering–like Flamingo…though it seems to not be great?–but for anything else will be kind of terrible, I am kind of shaking my head in amazement at how those got spec’d. Your 2070 is also going to be faster. I don’t know if that explains everything, people do run Rhino every day on much crappier laptops, make sure your drivers are all up to date.

After disabling the plug-in you need to restart Rhino.

Jim, really? Maybe you could give me a brief explanation for the difference so I can understand it a bit more? Our team isn’t very PC-savvy, though we probably should be. Just want to make sure I understand it correctly before I go looking into hardware changes for us.

Nathan, I can’t actually un-tick/disable that plugin, or any plugin, for that matter. Not sure why, but clicking the check box results in no changes whatsoever.

Well most of the time you’re not going to get any benefit from all those cores, it’s just the nature of “content creation” tasks. I mean that’s true of any CPU these days but newer ones have less compromise on single-threaded tasks. And I don’t know how fast the whole platform could be, it’s meant for servers, optimized for stacking as many as possible in a rack, not performance.

Hello - please run SystemInfo in Rhino and post the results here.



Here’s the results of the SystemInfo:

Rhino 6 SR23 2020-2-24 (Rhino 6, 6.23.20055.13111, Git hash:master @ 8106edaa648ba209a8fc587f0f7fcccbaac09169)
License type: Commercial, build 2020-02-24
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: KBLASIUS-DSTKP

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 11-8-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 411.95

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-8-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18347.11581\5.5\Legacy\Flamingo.Legacy.dll "Flamingo nXt Legacy File Reader " 5.5.18347.11581
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”
C:\Users\kblasius\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18353.6521\5.5\Flamingo.nXt.rhp “Flamingo nXt 5.5” 5.5.18353.6521

Hello - so, if you disable the Flamingo plug-ins and close then restart Rhino, there is no change, is that correct?


Your video drivers are pretty old…is Windows up-to-date also??

I can double check the drivers and Windows updating (we’re all working remote, which means IT has to remote-in to our desktops and do all the updating themselves, as we have no administration rights)

Pascal, I’ve now disabled it, closed, and re-opened Rhino. It does seem like it is faster with Flamingo disabled, though it’s hard to tell if it’ll last as the slow-ness only seems to happen sometimes, if that makes sense.

Hello - if you can work for a while without Flamingo, it would be good to know if the improvement holds up and then degrades again if you enable Flamingo…


Hi Pascal,

I continued to work into the evening and resumed again this morning without Flamingo - things ran very smooth. However, about two hours ago, I’ve had to turn Flamingo back on to do some rendering and boy oh boy has it slowed down. I’ve been attempting to change the resolution, and just typing in a new Width and Height takes, no exaggeration, 5 minutes. Selecting a different resolution in the drop down menu yields no results - everything just freezes for two to three minutes before the menu appears to load and actually “drop down.”

Any thoughts as to why this might be? It certainly makes it difficult to produce renders.

@johnm - do you have any ideas about what to check here?

@kblasius - does the slowdown happen with any file if Flamingo is loaded or ones that have a lot of Flamingo materials and textures, or large files… or?

Are there textures that live on a network drive?