Very Slow Move/Gumball/Rotate/Mirror

I have a Rhino file with only lines/curves. The display mode is wireframe with the background color changed to match autocads. My TestMaxSpeed score was 100 times = 8.72 seconds (11.47 FPS).

Panning will occasionally go quickly, however sometimes it lags. Worse though is that moving, rotating, mirroring, anything with gumball has a very large latency. The file is 100mb but it shouldn’t be lagging this bad.

I have tried looking through many other forums attempting to explain similar issues. Have tried playing with OpenGL settings to no avail. Any sage advice?

System Info:

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Educational, build 2018-12-14
License details: Cloud Zoo. In use by: Drew Busmire ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DMSKEATON-PC

Quadro M4000/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 412.16)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-17-2018
Driver Version: 24.21.14.1216
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 2.3.18205.927
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - I guess the first thing to try is to disable Enscape in Options > Plug-ins page, then restart Rhino - any different?

image

-Pascal

Hi Pascal,

I tried disabling and reloading the file. It is still very slow.

Hello- did you close and reopen Rhino?

-Pascal

Yes I did.

Hello- try, if you have not, turning off ‘GPU Tessellation’ in Options > View > OpenGL page. Also, how many curves are we talking about here?

-Pascal

I tried GPU Tessellation off. It helps a bit with panning but not with moving objects.

Curves in the scene are around 50,000 but they are not all displayed at once. I should note when I try to move something I am only trying to move a single curve, not the entire file

Hello - does the number of displayed curves impact the lag that you report?- can you find about the number where things feel correct?

-Pascal

I reduced it to 3 visible curves and it still is lagging the same amount. I would try to copy to a new file, but I have extensive layouts setup that would take a long time.

Can you please send us the file? (zip and upload to www.rhino3d.com/upload, to my attention)

thanks,

-Pascal

Uploaded

Hello got it, thanks - I can select and drag or move objects

170 hatches, 1852 block instances, 41 text dots, 37323 curves, 13 texts

with maybe a 5 second lag - is that about what you see?

-Pascal

Yes 5 seconds or so. I am not selecting everything at once though just a single curve.

Ah, OK - here a single curve moves as expected. I see a lot of layouts - does it matter whether you are on a layout or model space?

Also, can you please export your special display mode and post the ini file here?

-Pascal

Hmm. Yeah we need all the layouts for the set we are developing. It seems that it is slow both in model and paper space.

Can you try one more thing - open Rhino in Safe Mode (there is an entry for that in the Windows start menu) - does that behave any better?

-Pascal

Hi Pascal,

Safe Mode seems to be performing much worse. Now the panning/zooming is incredibly slow too.

Time to regen viewport 100 times = 450.84 seconds. (0.22 FPS)

Hello - just test the move-one-curve in Safe Mode - a lot of stuff will be crappy in Safe Mode, since it basically blocks your Open GL. It’s only a diagnostic tool not a real working mode.

-Pascal

I tested moving one curve, It also seemed to be just as slow as non safe mode.

Hmmm. Does this show up in any file? Or only on these very complex ones with a zillion curves and blocks?

-Pascal