Very slow display, not usable

We haven’t worked on performance improvements with respect to shadows lately. It is very likely that nothing has changed.

Hi I’m having the same issue as @Charles. I’ve just installed the latest WIP and I noticed something. When I zoom extents the view rotates at a normal speed when ghosted, but as I zoom closer to an object it slows down to the point that when I’m close enough to the object that I want to work on it’s impossible to rotate the view.

The strange thing is, it is completely opposite in Rhino 5, except that I can still work with the model.

Just thought I would add my two cents.

Thanks,
Jon.

Steve,

this ultra-slow performance is not any better in the WIP (6.0.17123.9201, 03.05.2017).
Also the new GPU tesselation doesn’t help when it comes to mesh display.
The GPU tesselation ‘only’ speeds up wire display dramatical.

It is not about shadows.
The bad performance is only when it comes to mesh display.
Wireframe is good.

I know the MS Surface is not a high-end PC.
But when V5 runs god, V6 should too.

3 Likes

I agree that this is an important selling point. Shipping V6 with both new and nice looking display modes and also simpler display modes that runs as fast as V5 is important IMO.

I’m not ready to start shipping “dumbed down” modes when we don’t fully understand the problem yet or have given up because we don’t think we can further improve things with the new features. I think we are working with an isolated case here and in general you should be seeing significant performance improvements in many areas (not all areas yet.) Please remember we have only still working on performance.

I’m getting pretty confused about what specifically you feel is the “slow” part of display on your Surface. Would it be possible to send me a model set to a specific display mode that is slow? Thanks

4 posts were merged into an existing topic: New V6 Display Faster: GPU Tessellation

Steve,

I don’t think so.
The graphics device in our MS Surface is a quite common.
And yes, I know it’s low-end.

Should.
That’s why I report this case.

That’s why I report this case.


It is not that complicated and you don’t need a specific model to test with.
Just have 3 cubes.

Orbit in Wireframe mode.
Orbit in Shaded.

Ok, you don’t have such a PC.
Get one:
https://www.amazon.de/Microsoft-Surface-128GB-Speicher-Win10/dp/B013UY0C28/ref=sr_1_2?ie=UTF8&qid=1494399730&sr=8-2&keywords=Surface+3

The issue has nothing to do with the new GPU tesselation.
Wireframe is acceptable to ok before this came up.
With GPU tesselation Wireframe display is very good.
It is about the SHADED modes.

As Holo says, it will be difficult to sell updates or new Rhinos when also new hardware is needed.

Sorry if I misled you to think that I only thought this happened on this single isolated computer. I was referring more that this may be more isolated to a specific set of hardware.

If you create three boxes in V6, what do you get for testmaxspeed in shaded mode?
If you create three boxes in V5, what do you get for testmaxspeed in shaded mode?

Could you provide the contents of the OpenGL page for V5?

Thanks

Hello @stevebaer,

ok, here it is:


Testmaxspeed with 3 cubes, Perspective viewport maximized, AA 4x:

Shaded:
V5 0.78
V6 4.84

Wireframe:
V5 0.7
V6 1.22 with or without GPU tes.

Good that you asked for the values, now we know V6’s display is only half as fast as V5…

Q:
Can it be that it has to do with the DPI aware line weight?
Is it possible to switch off the feature to test this?

Thank you.

It is possible since V6 is DPI aware so it may have to be computing pixel colors for four time the pixels. This isn’t really an option that we can turn off since it is an application level setting. That said, I work on several high DPI computers for V6 development and am still seeing much faster times in V6 than in V5. This leads me to believe there is something we are doing in V6 which the driver on your computer doesn’t like.

I have picked up several used computers for testing and will start looking around for a Surface 3.

@stevebaer @Charles

Sorry I’m late to this party…I just saw this…

V6’s Shaded display is significantly different than V5’s…in that it’s ALWAYS using shader based rendering, which currently only implements Phong shading… Shaded mode uses three custom lights, which means millions of per-pixel lighting calculations are going on per frame in V6’s Shaded mode, whereas, ZERO are occurring in V5’s… For a more valid comparison…You really should CHECK the “Advanced GPU lighting…” setting in V5’s Shaded mode…that will cause V5 to use shader based, Phong shading as well… Pretty sure the results will be much more comparable.

That being said… It has always been my intention to write a per-vertex lighting shader for V6, once most of the new architecture settles down. I’m also pretty sure I can get a shader working better and faster than the fixed function OpenGL pipeline, which is what V5 uses by default for Shaded mode…but won’t really know until I start digging into it.

Until then, Shaded mode will continue to use complex shading and lighting calculations…which will/does impact performance, especially on lower end GPUs.

-Jeff

@Jeff
You are right, Advanced GPU lighting was off, I forgot about it.

Ok, new values:
V5 Shaded Advanced off: 0:84
V5 Shaded Advanced on: 2:25
V6 Shaded: 4:45

When we see the 2 latter values, it is still only the half.


Q:
What will be the advantage of the new method in V6?
For me as a dummy it sounds like a lot of work for performance problems.
Of course, that can not be the truth :innocent:

Thanks,
Charles

@Charles

It still seems odd that it’s 2x slower than V5.

I have attached a Device ID application that will identify your exact GPU… Unzip it, and run DeviceID.exe…and allow any security stuff that pops up to go through…it’s safe, I wrote it :slight_smile:

Take a screenshot of the dialog that pops up and post it.

Thanks,
-J

DeviceID.zip (33.1 KB)

When you maximize your viewport in V5, what width and height does the viewport properties read?

Same question for V6.

I’m trying to determine if Windows is scaling your V5 due to high DPI

1890x1218

1918x1108

The difference is because of the viewport tabs and the toolbars in V6.

No Windows scaling, V5 is not blurred.

@Jeff

Hello Jeff,

not sure if you changed something in the meantime, so it is just a remark:
The display is still slow when it comes to shaded modes.

Charles

@jeff
@DavidEranen
Hmm, still the same in the current WIP 6.0.17220.11131, 08.08.2017.
Can I do something to help to find the cause?

Charles

Hello to everyone,
I have just found this discussion, so I am joining it, hoping to provide some valuable feedback. Like Charles, I am experiencing a very slow graphical performance in Rhino 6 too (I also tried to explain in another thread), which makes it hardly usable, the rare times it doesn’t even freeze/crash my system and I have to reboot it. Therefore, I thought about doing a little video showing what I see on my system, which, despite being “vintage” according to Apple, has worked beautifully on Rhino 5, even with complex models. This vintage system is a Macbook Pro 17", with i7-2860QM 2.50 GHz, AMD Radeon HD6700M, 12GB RAM, running Windows 7 Pro 64bit on Bootcamp. I have used the file called “Finished Detergent bottle.3dm”, which can be found in the Level 2 training. I have then set up on both Rhino V5 and V6 a Turntable Animation of 30 Frames in Shaded mode and recorded the Animation Preview with my phone on a tripod. As you can see, the rotation in V6 is superslow, while in V5 it is almost instantaneuos. It takes me long time even just to open the same file. You can find the recorded videos at the following dropbox links (sorry for the quality):


I hope this will help to move forward.

@luca_biselli Thanks for the videos.

What is the resolution of the viewport when maximized? Are you getting similar performance results when rotating the view with the right mouse button held (instead of using turntable)?

-David