Vector CrossProduct bug?

unhandled

#1

Hi @DavidRutten, i am facing below using GH in RH6:

Is there maybe something wrong using VectorCrossProduct ?

_
c.


(Dale Fugier) #2

Hi @clement,

The attached seems to work:

clement.gh (3.0 KB)

This too:

import Rhino
x = Rhino.Geometry.Vector3d.XAxis
y = Rhino.Geometry.Vector3d.YAxis
z = Rhino.Geometry.Vector3d.CrossProduct(x, y)
print z

What am I missing?

– Dale


#3

thanks Dale, you’re missing nothing, but i did.

:man_facepalming:

I just found that this is not the vector cross product i am using in the first post. You’re using the “right” one which explains it.
_
c.


(Dale Fugier) #4

Nice! I think I’ll call it a day now that I am ahead…

– Dale


#5

The CrossProduct component above is actually from the cycles for grasshopper shader components @nathanletwory. I’ve just double clicked on the canvas and typed “Cross…” then inserted that in the believe i could use it on 3d vectors.

The python editor on the left was shown for reference only, it gave what i expected.

_
c.


(Nathan 'jesterKing' Letwory) #6

The shader nodes don’t do any meaningful data operations in Grasshopper. They really only front the shader graph nodes in Cycles.


#7

Thanks @nathanletwory, since i cannot use cycles anymore using the GEN1 AMD card i guess i can remove that. I do get this on every GH start as well:

grafik

What do i need to remove to get rid of it without spoiling my install ?

_
c.


(Nathan 'jesterKing' Letwory) #8

Well, you can just remove the GhShaderNodes files. There were some changes to the shader nodes in the wrapper code, your gha is probably out of date.

Note that you still can render using CPU… :slight_smile:

Edit: I am in the progress of rewriting the plug-in in C#


#9

Using the default install ? I do not have that to select as renderer:

btw. i stil can render using my old card in blender using this stupid workaround,but i’ve been more into eevee…
_
c.


(Nathan 'jesterKing' Letwory) #10

I meant using Raytraced. The CyclesForRhino plug-in is actively blocked by Rhino.

Re stupid workaround: it is possible to get your old card working, but it will be really slow.


#11

OK, tried that using raytraced and stopped after it had 8 samples done in 1minute using an old dual xeon 3Ghz. Only thing which is running is ProRender but there are too many issues with that like rendering without a sample goal etc. Is this beeing worked on during V6 ?

_
c.


(Nathan 'jesterKing' Letwory) #12

I don’t know what the dev target is for ProRender.