VALabs Slab Join cannot join multiple or single part Slabs

Slabs are not joined correctly if one of the Slabs has multiple parts, or points very close to each other?. The result is deletion of some, or all parts. See example below.

Slab A and B are shown selected in separate snapshots, then A+B as a Join result is shown.

Even if i add a boundary to fill the first Slab, Join Fails



When isolating the issue and trying more clearing up, it seems that point proximity or solution tolerance may affect the result. After adding a bounding rectangle to the small slab, Join succeeds. With Red are the added rectangles that did not solve the issue, with green the rectangle that solved the issue.

Also, if manually moving the points in a certain way (see gif below), join succeeds. Is it a matter of geometry? Tolerance? I know the file is “dirty”, with these points and i normally avoid them, but it may be of interest for your algorithms.

Rhino file is also provided.



Slab_Join.3dm (329.8 KB)

Slab_Join_Solved

Hi @flatform,

I have been testing it and I get the same result. I have just reported it so I will let you know when I find a solution.

1 Like