VA gone from GH

Some time ago I have lost all VA components from GH.
VA is still present in Rhino though.
I have tried repair the install with most recent version but it didn’t kelp.

Hi Piotr, do you mean that if you run any VisualARQ command in Rhino it works, but you don’t have the VisualARQ components in Grasshopper?
If you type any VA component’s name in GH, does the search find any?

It was a case till now. Somehow they appeared again after I triggered some VA command.
Second session and they are gone and appear again after some VA command, but before, I get this:


Please note, it’s one out of many that is missing.

The biggest problem, in my case, is disappearing GH setup with loosing tiles, wires and dead components.


This is a fragment of 4500 tile def with VA spread all over it. It takes very long time to restore what’s missing.

Hi Piotr,
This looks like these definitions are opened before VisualARQ is loaded, and therefore, GH misses its components.
Just ensure VisualARQ loads before running these GH files. Actually, when you load VisualARQ, GH loads automatically since VisualARQ uses some Grasshopper definitions in its styles.

My GH loads before I even type it, which I find very annoying because it takes long time here to do so.
How do I ensure VA loads before GH?

Hi Piotr, we have plans to improve that, so GH only will load when is strictly necessary.
But if you have a big number of add-ons installed, GH will take the same time to load.
When VisualARQ loads, GH loads too, but always right after VisualARQ, so you should always see the VA components there. The problem you report will only happen if you load GH before VisualARQ, which can happen when:

  • You open a Rhino session where VisualARQ is not installed
  • You open a Rhino file with no VisualARQ data
  • You don’t run any VisualARQ command

Hi Francesc
My case, clearly is different here.
After launching Rhino sessions the VA toolbar is present, all commands active
image

When I launch GH there is no VA toolbar

and it will only appear after I do something VA-related, eg. profile from Curve.

I only figured this out this morning.
Launching any VA command before GH could prevent me from loosing VA components in script but this is not the workflow i would like to experience.

Also, for the sake of clarity:
Please remove all of it from Input and make it’s own ribbon panel

Hi Piotr, the fact you see the VisualARQ toolbar doesn’t mean VisualARQ has loaded. Check the command line to see if VisualARQ has loaded or not before launching Grasshopper.

Well, I understand that those components there might look a bit intrusive, we decided to put them in the “Params” section in the GH ribbon in order to integrate VA as much as possible with GH. That way all components of the same type (Params, Inputs, etc…) can be found in the same place, no matter if they come natively from GH or from VA.

With the same principle, there are actually some other components provided by VisualARQ that are integrated into the Geometry tab:

I know this decision might be controversial when you are used to use Grasshopper without VisualARQ so we are keen to discuss it further and hear from opinions.

Both of your stuff are set for auto-launch (plugin manager)
image
yet they not loading. I just checked the command bar.
Is it by-design or something is not working here properly?

Hi @Piotr,

Tibidabo and VisualARQ are not loaded at start by default, they are set to be loaded by request.

There are four known situations that may provoque VisualARQ to be loaded at startup:

  1. “Levels” or “Sections” panels were enabled when you closed Rhino the last time. Rhino always try to restore the last state of Rhino, so any opened panel must be shown, so Rhino loads all required plugins.
  2. The template used in Rhino has VisualARQ data.
  3. There is a VisualARQ command in the list of commands to be executed when Rhino loads.
  4. A third-party plug-in is linking VisualARQ Script API. This is very rare, as there are no known plugins that link with VisualARQ yet.

If you close all VisualARQ panels, reset the Rhino default template, and clear the list of startup commands, VisualARQ will probably stop being loaded at startup.

Enric