V8 - units "dropdown" - please fix

In V7, in DocProperties>Units, the units dropdown looks like this when you hit the arrow:

Note the entire range is visible, all the way to the top.

In V8 it looks like this:

Note that there is a scroll bar and that it’s scrolled down from the top already so that the uppermost units in the list are not visible. This is true even if the dialog is pulled way down, long enough for the list to be shown without a scrollbar.

So for example if one wants to change from Meters to Millimeters, one has to scroll up. This is not how “dropdowns” should work.

If you think this is minor, it is not. I had an Italian-speaking colleague contact me yesterday wondering why his V8 was always exporting things at the wrong size. He sent me a file. When I went and looked at the units, I saw this:

He, not being English speaking and having no idea about US measurement units, not seeing millimeters in the list, he assumed that “Mils” was short for (or a misspelling of) millimeters.

Please make it so that if there has to be a scrollbar in the units list, that it always starts from the top. And make the scrollbar go away if there is vertical room on the screen for the entire list.

(who models in mils anyway??)

Who is modelling in Gigametres or AU?

“Is your planet far from the origin?”.

It would be nice if a user could make a selection of units and the settings would only show these instead of a ton of personally useless units.

Got that, thanks.
Hm, though here, @Helvetosaur , I do not get a scrollbar, I get the full list.

-Pascal

1 Like

Really? Hmm, you must have a different version than me - it’s been this way here in V8 since as long as I can remember.

@pascal I see similar to @Helvetosaur:

Version 8 SR7
(8.7.24107.13001, 2024-04-16)

Does it depend on screen resolution?

Possibly - I have a 4K screen at 150% display scaling…

Also happens on my PC laptop with a 4K and 225% scaling.

It’s good on my Mac laptop, I see the whole thing, no scrollbar.

I have a 4K monitor and see the same results with:
1920 x 1080 100%
3840 x 2160 100%
3840 x 2150 150%

Rhino 8 SR7 2024-4-16 (Rhino 8, 8.7.24107.13001, Git hash:master @ aa01e3b9820d84a48c2a812d24f0cf42379ee3d8)
License type: Commercial, build 2024-04-16
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 64GB)
.NET Framework 4.8.9232.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 12-6-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.33
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2023
Driver Version: 31.0.15.4633
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24107.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

OK, thanks all,yes, I see it on Windows, not on Mac - I always miss the ‘mac’ tag on posts, and for once this time I saw one!, but is a Windows bug not a mac thing.
RH-81599 Make sure to show all units from the top

-Pascal