V8 and v7: Cycles shadow banding in Raytraced

@nathanletwory
I’m testing out V8 on some old files and Cycles seems faster and more responsive, but can you please check if there is something going on with the shadows in Cycles that causes this bad banding? Because Cycles and the viewport can handle gray much better than what we see in the shadows areas, so it seem strange that this is just a “lack of bit” issue in the viewport.

what happens if you mess with the dithering settings

when seeing a behavior in a wip, especially with an older file, I might suspect old settings getting “stuck” or interpreted differently, and such

1 Like

I’ll check that out, but where are they?
(02:44 here, so hitting the bed now, the super long summer days up here north messes with the need for sleep :smile:)
((Btw: this is what it looks like outside and the birds are singing already.))

2 Likes

here it is, in render settings

though it looks pretty extreme in your image, so not sure if there is more going on there

1 Like

Hi Jorgen - I’ve seen this, unpredictably, unrepeatably, when making changes to render settings or materials while the raytraced viewport is running - switching to wireframe and back sometimes helps. I have not noticed this in a while, here.

-Pascal

I see this every time I use Cycles, so that is strange Pascal, but you have to wait long enough, or toggle on Intel denoiser.

Here is a super simple scene I made in V8:
(Same color on sphere as on ground + 1 rectangular light)

But the banding is bad in OpenGL too in V8:

File:
Banding Ball V8.3dm (389.2 KB)

PS!
We really need a way to get to the post process stuff in the Render Tab. Toggling on Denoising is hidden in too many steps :slight_smile:

And PPS:
Here is the result in the Render Window when I do a proper render: (nice and smooth)

And you can see the banding appears after a few houndred iterations with out the denoiser too:

If I stop it at 100 with out denoising you can see that the noise works as a dithering and it isn’t easy to see:

How many bits are the display pipeline? I know @nathanletwory told me once, but I have forgotten :slight_smile:

Edit: If it’s just 8bit per channel I guess this is what causes it:
image

Edit on the edit:
Nope, that isn’t it because if I save the render to a BMP then that is 8bit per channel and it is smoother:

Thanks, Dithering doesn’t change anything in Cycles in those dark areas. At least not here on my systems (Intel CPU + RTX + Intel Denoiser)
I didn’t try the nVidia denoiser, but I don’t expect any change.

You should find that using _Render the banding goes away. Rhino viewports currently aren’t 32bit floats but hopefully will be before release.