V7 raytracing mode : default rays number too high


In V7, the “raytracing” mode default ray number is too high for realtime display in the viewport.
I know it can probably be tweaked in the settings, and I will do that once Rhino unfreeze in probably 10 minutes when it finishes computing the 1000-rays raytracing render I didn’t ask for…

For a comparison, in Blender the default rays number for realtime display in the viewport is 32 and 128 when you formally render a high def image with the render function :

Wait now it unfreezed I looked in the setting but can’t find the option, is that actually possible to tweak the number of rays per pixel for realtime display ?

EDIT : ok I realize the raytraced mode actually use the render settings. It would be cool to have different setting for realtime disaplay, like Blender

Hi Felix - to change the number of samples for the Raytraced display mode, just click on the sample count in the viewport and change it there:


1 Like

Thanks @wim !

What about the maximum bounces per ray, can I change this ? It still renders pretty slow…


1 Like

Hello - you can set the desired maximum in your template files as well so it is just there when you start. Bounces are set for the full render in the Render panel > Advanced settings but I am not sure if this affects the raytraced display - @nathanletwory - can you set us straight on that?


Those also affect the Raytraced view. Once you make changes to them you’ll have to toggle the display mode.

FWIW in Rhino 7.1 diffuse bounce is set to 4, others are at 32.