V7 File with no objects over 1 MB - Why?

I turned the grid dispaly off and the file size remained the same.
I made the grid very small, 2 grid lines, and the file size remained the same.

I viewed the file in an online hexadecimal view. There is over a megabyte of a repeating pattern which presumably is just a filler, not data.:

I didn’t mean just the grid. I’m sure there are plenty of gray dots to make up an image of an empty scene. I probably shouldn’t have posted a reply in this thread as I haven’t had the time to give you a quality answer.

Steve, thanks for looking into this.

What is the preview image used for? Did V5 and V6 have preview images? If they did then what changed in V7?

A much smaller amount of repeating lines are the V5 and V6 files. Those lines contain all 5’s when viewd with a hexadecimal viewr.

A guess, and only a guess. The repeating pattern is used to increase the minimum file size so that file writing (and/or file reading) talks longer, possibly to resolve an issue with cloud storage.

Preview images are used for displaying thumbnails of 3dms in Windows file explorer. Requests come in to make these images bigger and they have grown in size over different versions of Rhino.

I’ll try to spend time tomorrow to give you better information than what I have already provided.

I was wrong about the preview image.

There is something else at play here. I opened your blank file and then saved it under a different name and ended up with a 20kb 3dm. Do you have any 3rd party plug-ins installed? SystemInfo will tell you that if you aren’t sure.

No third party plug-ins were loaded. Orca3D is on the computer but I disabled it from loading. Also checked and the file isize was the same with it loaded. SystemInfo results are at the bottom of my first message.

I was put onto this by the file which Miano loaded in this thread. Lines through Points - #11 by davidcockey Zipped it is 26 KB. Unzipped it was 2,859 KB. Miano remarked that he frequently sees 100:1 compression ratios which indicate to me that are proably a lot of repeated bytes.

Interesting when I opened Rhino 7 in Safe Mode and saved the file was smaller than the files from V6 or V5. Files are in first message Also looked at the Safe Mode file contents and it does not have the repeated bytes.

Moved to my desktop from my laptop. Opened V7 and saved. The file is 5 KB. V7BlankDesktop.3dm (4.4 KB) SystemInfor that desktop is below.

Added: Opened the 5 KB file form my desktop on my laptop and saved it. Now it is 1455 KB.

Rhino 7 SR4 2021-2-9 (Rhino 7, 7.4.21040.13001, Git hash:master @ 3c3a501e58b2e53701926611ee3535d3cde4cd9e)
License type: Commercial, build 2021-02-09
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon HD 7700 Series (AMD) Memory: 2GB, Driver date: 8-21-2020 (M-D-Y). OpenGL Ver: 4.6.13596 Compatibility Profile Context 20.10.35.02 27.20.1034.6
> Accelerated graphics device with 8 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 8-21-2020
Driver Version: 27.20.1034.6
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Orca3D V2\Orca3D.rhp “Orca3D” 2.0.20.0
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21040.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21040.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21040.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21040.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21040.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

PanelingTools and SectionTools don’t actually ship with Rhino. Try disabling those, restart Rhino and save. I wouldn’t think those would be the cause, but it is good to eliminate possibilities

Already did. Had all plug-ins disabled and the saved file size was the same. I will repeat disabling PanelingTools and SectionTools to verify.

Another thing to try is to send me your settings.xml file. Maybe some setting was adjusted that I don’t know about.

Where do I find settings.xml file.

Disabling DevSrf, PanelingTools and SectionTools did not make any difference.

I also tried resetting Rhino Options to defaults. No difference.

settings.xml files:
settings-Scheme__Default.xml (45.1 KB)
window_positions-Scheme__Default.xml (28.9 KB)

I have Rhino 8 WIP loaded on my laptop which saves large files, but not on my desktop which saves small files…(8.0.21005.12305, 1/5/2021).

V8 WIP file size without geometry is 5 KB,

Weird; I hate mysteries like that. Thanks for letting me know

@stevebaer Now deleted post was wrong. I tested V6, not V7, by mistake. Problem still exists after restarting computer.

I uninstalled V7 and V8 from my laptop, and then reinstalled V7. The blank file size is still over 1 MB.

Rhino on mac saves a much bigger preview image than Windows does - save an empty file on mac and it is 2.3 MB, I believe this is mostly high-ish resolution preview. I think.

-Pascal

@pascal The larger file size only occurs with files saved using V7 on my laptop. Files saved using V7 on my desktop are much smaller and the same size as files save on either computer using V5, V6 and V8 (laptop only). So it does not seem to be preview image related. @stevebaer originally guessed it was image preview related and then changed his mind.

As described above the difference in file size appears to be due to a repeating pattern of bytes.

I’m still not sure what the cause is yet. It still may very well be a preview image.

A post was split to a new topic: 7.4 Breaking Changes

:rofl: