V7 Curves appear through objects in Rendered mode in Perspective and the other primary views

In V7, some curves which are behind surfaces are visible through the surfaces in Rendered mode.

Regards, Garry.

Rhino 7 SR1 2020-12-2 (Rhino 7, 7.1.20337.05001, Git hash:master @ 5c341516d2f548c8e4859a9aed89600f09c5203a)
License type: Commercial, build 2020-12-02
License details: Cloud Zoo

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-11-2020 (M-D-Y).
Primary OpenGL: NVIDIA GeForce RTX 2080 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 1-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.23

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-31-2020
Driver Version: 26.21.14.4223
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

HouseRemodelZHTP3V6C.3dm (18.5 MB)

V6…

V7…

your nvidia driver is a bit old…you may try an update (use the custom option>clean install)

I see that here as well…
ClearDrawOrder sorts it out…
-Pascal

Hi Kyle,

I have updated the driver, but the problem still exists. It looks like @pascal can see the problem, so it will receive attention. Thank you for the suggestion.

Regards, Garry.

does the cleardraworder command work for you as well?

Kyle,

Yes it did.

@pascal - Will you be able to devise a solution within Rhino 7, or will that command have to be used for every model?

Regards, Garry.

ideally it’ll only be needed on models that show the issue. If its happening on every model please let us know.

Hi Garry - the draw order is real - that is, it is applied to some of the curves and in V6, the order is respected in Shaded mode

image

but not, it seems, in Rendered. Still poking… but right now I call this a bug in V6…

-Pascal