V7 adv. settings - Options.UIPaintcolors - something is haywire

I noticed this at first:

image

This setting was the only one that didn’t have a color swatch and look like the others. I double clicked on it anyway and got this:

image

I was curious, so I hit the Set To Default button, now I have this:

image

I don’t even know what this controls… I tried setting to a bunch of different values, I didn’t notice any change anywhere.

??

(7.1.20314.23101, 09-Nov-20)

More fun with UI colors:

Setting the “Edit box background” to something other than its default white results in this here:

(I set it to light gray, but it doesn’t matter what value besides default, they’re all black)
In any case the control doesn’t seem to be working - as it doesn’t indicate which color has been set - it’s always white. Interestingly enough it does change one tiny thing, for example I set it to green, and here’s what changed:

image

I think I’ll stop messing around with it here, as most of the other settings I have no idea what they do - and the important ones - layer panel background, inactive tab color etc. don’t seem to be there anyway.

This part does not feel like release version software sadly. :slightly_frowning_face:

(Just for reference my vid card is a GTX 980 Ti 6Gb with the latest available 457.30 drivers.)

1 Like

I think the color shown in your screenshot is completely transparent.

I’ll check that, but I just clicked on one of the color swatches in the color picker, such as “light gray”. There’s no indication that those colors could be transparent.

EditBoxBackground is a special case as it is computed based on other colors if it is in it’s default state which is called an “unset” color. When the color is set to something other than this “unset” value, that color is used.

OK, correct assumption, don’t know why the color picker alpha slider was set to 0, I didn’t set it that way.

What other colors? I changed the Window 1, 2 and 3 colors to a darker gray than default, but the edit box background didn’t change.

Text color is used for computing the edit box background when the item is unset. The unset color is completely transparent which is why the color ui had transparency set when you tried adjusting values.

Brian wrote a color scheme plugin available via the package manager which may work better for you if you are just trying to darken things up a bit.

OK, thanks Steve. That solves one problem, I guess having a different color for an inactive panel tab is not a possible adjustment though?

I tried that, the results are posted in a response in another thread:

I will try it again some time.

I don’t have an answer for that right now. I’m not at my computer

OK, thanks anyway for your Sunday answers! :smile:

Cheers, --M

One last “Note” here - the “Notes” panel does not take on the same color as the Layers panel background when modified - it remains white.

Also, found this one - it’s “Window Color 3”

Hello, I have similar issue with Box Edit window, I have almost completely redone my UI as I wanted but here it is how Box Edit appear now.
image
As you can see it is very bright text on white background in units area.
I’ve checked every single option which could affect this issue in Document Properties>Advanced, but nothing worked. I can change color of text in command prompt and in not-editable parts of texts. But color option for text that could be edited is missing in options.
Am I missing something here or there is really no option to change that and to be clear I do not want to mess with High Contrast settings for operating system.

This setting seems to be the one here:

I do not have a “High-Contrast” theme set in Windows though.

Not a case here :frowning:
Zrzut ekranu 2020-12-10 131042
Maybe something else from this options here is affecting it? But I changed all of light colors to check if they do something.

Send me your settings-Scheme__Default.xml
located at
%appdata%\McNeel\Rhinoceros\7.0\settings\settings-Scheme__Default.xml

I’ll can use that to try and repeat what you are seeing

Ah, looks like the BoxEdit panel is not programmed that way… @stevebaer


Got it; thanks Mitch. I just created a bug for this at
https://mcneel.myjetbrains.com/youtrack/issue/RH-61947

I just tested this with (7.2.20344.17011, 12/9/2020) and it’s working as expected. You really have to restart Rhino in order to see all of the color changes.

1 Like

All right than, I do not thought that restarting Rhino will solve this, too simple solution :smiley:
All changes appears immediately, except this one. Now it is working as it should, thanks for giving that hint. I’m laughing of myself.
Maybe some information will do, like: ‘Some changes will be visible after restarting Rhino’ or maybe there is and I have notifications turned off.

The information here is very useful to set up a proper dark theme.

I did notice another area where I am not sure if a setting exists or doesn’t apply to it - in text, the dropdown menus appear rather white.

image

1 Like