V6 Render Display Mode - Lines Visible Depending on Viewport/Camera Angle (Latest WIP)


#1

This may have already been reported – noticing that depending on viewport / camera angle lines visible (shouldn’t be)

Here’s an example.

Best,

jvm

Lines coming through in the “DOV Cosmetics” from this angle that shouldn’t be.

Lines correct in the “DOV Cosmetics” from this angle


#2

FYI, this is still showing up in the latest V6 WIP (May 23).

jvm


(Pascal Golay) #3

@jvm33 Jim, can you send me this file?

thanks,

-Pascal


#4

HI Cal-

Here’s a link to the file on Dropbox (Link removed)

Best,

Jim


(Pascal Golay) #5

Hi Jim - so far I do not see what you’re showing - can you please export the display mode from “Options > View > Display modes” that is in use for your screen shots and send me that or post it here?

thanks,

-Pascal


#6

Here’s the “rendered” display file. Also happens with Arctic.

jvm_Rendered.ini (11.3 KB)


#7

One other thing…it seems to act differently with different camera lens lengths. I had a lens set to 18mm and it was definitely noticeable and then when I changed it to 55mm less so. I’m right clicking on my mouse to move the viewport into position and even that, depending on where I stop, seems to effect whether I see lines or not.


(Pascal Golay) #8

Jim, it looks like your misbehaving objects are using a custom display mode (SetObjectDisplayMode) What if you set that to ‘UseView’?

-Pascal


#9

I changed it to ‘useview’…still happening.

Must be on my side…when I capture the file and look at it, it doesn’t have the visible lines…but the display shows it – here’s a screen capture of the same thing.


(Pascal Golay) #10

Hi Jim - Hm… what is your video card? Newish drivers?

-Pascal


#11

Hi Cal-

Card is NVidia GTX 670M - it’s got the latest/most up to date driver.

Jim


(Pascal Golay) #12

Hi Jim - please try hiding the cut-out figures that are behind the camera, as well as anything else that is not in the view. Does that make a difference?

-Pascal


#13

Yes it does make a difference. I eliminated the cut out figures behind camera. I also noticed a straight line running out of camera view. When I deleted the line on the ground plane, the see through lines on the unit were no longer see through.

Line Running Off Viewport Render - Lines Visible through “DOV Cosmetics” – probably hard to see in this image but it’s happening.

Line Deleted - Lines not visible through “DOV Cosmetics”


(Pascal Golay) #14

Hi Jim - it does not have the same bleed-through effect here, but if you turn on the camera (F-6) for this view in a 4view setup I bet you see that when the line comes into the camera frustum is when you see the bleed-through - I think, especially with a short lens, the depth sorting is suddenly asked to deal with a much bigger spatial depth when the line comes in, and the precison of the sort drops off.

-Pascal


#15

Yes, makes sense…it wasn’t happening when viewing in the other direction.

jvm