V6 point (.txt) import and export changes from V5 which I think are bugs

export

#1

When I export points as .txt files, they’re written with 3 trailing 0’s:
49.627 79.117 64.836 0 0 0
49.961 79.052 64.612 0 0 0
50.09 79.026 64.456 0 0 0
Can these go away please? I just want the coordinates as it was in V5.

When I import points from .txt files, the options aren’t sticky between sessions: no matter how many times I check “Always use these settings do not show this dialog again”, when Rhino is reopened it reverts to the original settings. I preferred it sticky.

Thanks
Bathsheba


(Pascal Golay) #2

Hi Bathsheba, I’ll check this, thanks.

-Pascal


#3

Hi, I’m bumping this thread because both bugs are still present in the most recent update, and still messing with my workflow every day. I can code around the extra 0’s, which apparently indicate the color of each point, but the non-sticky import setting causes me nuisance clicks every.single.time.

Thanks!


(Tim Hemmelman) #4

Hi Bathsheba,

I’m working on hooking up a checkbox that will let you turn off vertex colors on export.

I have a question about your comments for import. I was testing this myself and I do see settings being saved to the setting.xml file properly. However, it looks like when the delimiter is a single space it’s not getting read back in properly. And to complicate the issue the plugin assumes, when you’ve turned off the dialog, that you know what you’re doing and know what the delimiter should be. But since the settings doesn’t read the space right it get’s reset to a comma (the default delimiter). So your file won’t read. When the dialog is turned on it reads the first bit of the file and determines what is likely the delimiter and presets the radio button to the appropriate choice. So, are you opening files that have a space for the delimiter? Does anything I just mentioned sound like what you’re experiencing yourself?

Cheers,
Tim


(Tim Hemmelman) #5

You can track progress on the export issue here. https://mcneel.myjetbrains.com/youtrack/issue/RH-46680

Waiting to here back before proceeding on any changes to the import code.


#6

Hi, thanks for looking at this!

I have some space-delimited files but more tab-delimited ones, and I see identical behavior with both: the delimiter I choose is remembered within Rhino sessions, but resets to comma between sessions.

If I don’t open the dialog it silently fails to read the file (reports success but nothing is read), and if I do open the dialog it’s preset to comma. So I’m never seeing the radio button preset to a choice that is read from the file: it’s always comma.

I didn’t know pre-reading the file to try to figure out the delimiter was a thing, and now I’m curious if that ever worked…OK, back in Rhino 5 I see it working for spaces but not for tabs. So if you get it working for both, that might be the first time it ever has. I’d use it every day.

Thanks again,
Bathsheba


(Tim Hemmelman) #7

I’m working on a settings fix now that will get rid of the reset between sessions. See https://mcneel.myjetbrains.com/youtrack/issue/RH-46704 to track progress.


#8

Yay thank you!


(Brian Gillespie) #9

RH-46680 is fixed in the latest Service Release Candidate


#10

Yup, colors can now be turned off for points export. Thanks!!

One down, RH-46704 to go.


(Brian Gillespie) #11

RH-46704 is fixed in the latest Service Release Candidate