V6 Goal: Display Performance

This should not be the case anymore for polysurface and extrusion wires with the GPU tessellation option. See:


Wow, that’s a really big step forward. I’m very impressed!!!

Also my current heavy production models can be easy manipulated now. It’s like Christmas and birthday at the same day. :slight_smile:

@stevebaer , thank you for the note to me.


That makes my day to hear; great!! Thank you for testing. I’m assuming you are on an nVidia GPU?

I was seeing around 3x improvements with my newer Intel Iris GPU, but one of Jeff’s fancier nVidia cards was seeing TestMaxSpeed go from 10 seconds to under 1 second for wireframe with that model.

Yes, I use a GTX780 here. The bike model is from 12s down to 2s, so it’s approx. 6 times faster now. And working with heavy models is like working with light models. It’s so great, since my model complexity is extremely grown over the last years. I’m happy.

For further improvements - I tested my worst model and it works better too. I see a working dynamic switch to wireframe mode. That’s fine, I missed it at Rhino 5. Only the time for switching between both modes is approx. 1.5s and could be faster. Maybe it can be optimized. Interesting is that my GTX780 is used at max 37%. (It’s a very heavy model. It’s not the typical complexity of my daily use.)

1 Like

Yep, when this works it blows away the old display speed. I’m still seeing problems with AMD and am setting up a test computer with an AMD card to see if there is anything we can figure out that we are doing wrong on that hardware.

Is your “worst” model composed of more than just polysurfaces and extrusions? I haven’t implemented tessellation on curves yet and blocks still need some love.

Here ya go. Please see this post

It’s a detailed train model, each wagon from a separate linked block file.

Thank you Steve… rushing my breakfast to get to the office to try it out !

stevebaer mcneel@discoursemail.com schrieb am Do., 4. Mai 2017, 06:51:


I tried with 10 of the bicycles, speed is as lightning.
Very very cool.

But I found a problem:
The isocurve settings don’t work anymore.


1 Like

That one is reported here: :wink:

Thank you Wim, I didn’t see.

I now tried with polygon models.
Impressive performance.

Hi, the display performance with WIP used to be faster than 5.0 on my laptop but now this is not the case.

I tried the GPU tesselation, but for shaded with edges it makes no difference.
(nvidia settings are on max preformance etc.)

Laptop specs:
Windows 10
16 gb

NVIDIA Corporation
Quadro K1100M/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 377.35
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Anything I can do?


Can you share the model you are using for testing?


There is something that I have been noticing for a while in V6 WIP display: after each view change (zoom, RMB-rotate), Rhino pauses for 0.5-1s (longer in shaded modes), before it gets responsive again. This is in more complex models, a simple models work fine. This is not dependent on AA, Shadows, GPU Tesselation (tried a lot of combinations) - this is not a new problem, before it was not bothering so much since I didn’t try to do real work in V6. Now is makes is really difficult, this micro-pause after each view change. The speeds within the move sequence before releasing RMB are much faster and nice now, but the lag between the moves is killing all the joy. V5 works fine here with zero-delays. Wondering if anyone else is seeing similar thing. Updated the drivers today, still the same:

NVIDIA Corporation
GeForce GTX 980 Ti/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 382.05
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version:

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

Hi @Jarek,

i see this too using (6.0.17135.12071, 15.05.2017) when i have a large mesh in the file and try to do anything like drawing a line or when asked to pick a point in any prompts.

It seems to be related to snapping in my case, if i disable OSNAPS it goes away. The delays are slightly longer here, approx. 1-2s but this might be my old systems fault. It does not happen in V5, though. ATM, i cannot use the WIP at all because of this.

ATI Technologies Inc.
AMD Radeon R9 200 / HD 7900 Series
OpenGL version: 4.5.13469 Compatibility Profile Context 21.19.519.2
Render version: 4.5
Shading Language: 4.50
Driver Date: 2-10-2017
Driver Version: 21.19.519.2

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB


Hi Clement,

the model I am testing it with has no meshes, just surf/polysurf, and enable/disable OSnaps does not make any difference, so probably a different issue. Thanks!


I haven’t seen this. If you have some case that you can repeat, I sure would like to try it out on my computer.

@stevebaer, 100% repeatable over here using (6.0.17139.2571, 19.05.2017).

Test Data, download this rhino scene, then import this obj file using the import option “Max obj Y to Rhino Z”.

Once the obj import is done, enable the OSNAPS: End, Near, Point, Mid, Cen, Int and try to draw a line or a point. I’ve found that any prompt asking for a point causes a halt of at least one second, sometimes 2-3 seconds while an hourglass is displayed. Navigation using RMB or Zoom using the mouse wheel during the prompts get noticably interrupted over here. If i diable OSNAPS, everything is running fine.

Display Mode is Shaded, using default settings. I can make a video, but the hourglass is not recorded.


I think I’m repeating this in shaded mode. You don’t see this in wireframe correct?

@jeff or @mikko, do you have an idea of where this bottleneck may be? It seems like the osnap feedback is getting really slow in shaded mode for he above model, but not in wireframe.

Hi @stevebaer, it super fast in Wireframe. I guess i’ve found why its slowing down. If you enable “Snap to occluded objects” in Modeling aids, its gone. So there must be some kind of occlusion test causing these freezes.