V6 Display Performance: Block Improvements

unhandled
wip-6-win-splash

#23

Objects moved to 0,0,0 - problem is still there. Added a split - split edges are looking fine, touching edges of the model still bad.


#24

Hi @stevebaer

I have tested latest WIP.
One reported issue is fixed (39428)
But the issue indicated earlier (#6) still is not solved.
I will try to prepare a clean example.

Thanks,
Dmitriy


#25

Models with heavy blocks now display properly, even in shaded modes with transparency, and strange artefacts that I reported by message are now gone (6.0.17143.8371)
I’m really happy of what I’m seeing here.

On the grasshopper side, there seems to be some trouble though.
When I open my definition, I get a stream of display pipeline warnings…


#26

Hi @stevebaer

Please see example below.
Block becomes invisible when I freeze the layer, the block objects belong to.

BlockTest_ToSteve1.3dm (242.4 KB)

Thanks,
Dmitriy


(Pascal Golay) #27

Hi Dmitry - I see that, thanks.

https://mcneel.myjetbrains.com/youtrack/issue/RH-39580

-Pascal


(Steve Baer) #28

@DavidRutten, have you seen these error messages? Sounds like it is GH specific


(David Rutten) #29

Can you upload this definition?


#30

Sent to David


(Steve Baer) #31

3 posts were split to a new topic: Dark Blocks


#32

I just installed the latest WIP update for Rhino 6 and I am no longer seeing any curves. I opened up a mesh file and was able to see curves there, but in wireframe and in any other mode, like ghosted, I cannot see any NURBS curves or isocurves belonging to NURBS surfaces


(Pascal Golay) #33

Hi Danielle - can you please run SystemInfo and paste the results here?

thanks,

-Pascal


#34

Rhino 6 SR0 2017-9-19 (Rhino WIP, 6.0.17262.13121, Git hash:master @
b8e026a9dd4d75945f767d2004f39144d076b81c)

Windows 7 SP1 (Physical RAM: 16Gb)

GeForce GT 750M/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: 12-24-2013
Driver Version: 9.18.13.3228
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp "Commands"
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp "Renderer Development Kit"
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp "Rhino Render"
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp "RDK_EtoUI"
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp "Renderer Development Kit UI"
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp "Snapshots"
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp "Cycles for Rhino"
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp "RhinoCycles"
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp "Toolbars"
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse"
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


#35

First things first - update these drivers to a more current version.


#36

Sometimes the blocks are not visible in parallel views. Have any suggestions?


(Steve Baer) #37

A post was split to a new topic: Block visibility change