V6-Display cuts in half when panning and rotating

This is a slight glitch I noticed with my video card. I think this is more related to the NVidia drivers than with Rhino although it is worse in Rhino than in my other 3d apps.
If I set my render mode to rendered.
When I pan or rotate the display, the image of say a simple cube splits in half or more parts looking like jagged lightning briefly, then the screen updates and displays ok. I see it worse in files that are heavier but I still see it even with a simple cube in the viewport and then just rotating or panning. I saw this slightly but no where near as marked in 3dcoat though there I have huge files and can rotate in real time with no degradation and this glitch is not noticeable only on rare occasion unlike Rhino where it’s constant.
I have two video cards but I have the NVidia set to use Rhino and I see Rhino reports Nvidia in the openGL section.
I know it’s probably is their win10 drivers but…

My specs are:
Latest Rhino V6 update (no V5 on this computer)
Computer MSI Leopard
32 gig ram
Operating System: Windows 10 Home, 64-bit
DirectX version: 12.0
GPU processor: GeForce GTX 960M
Driver version: 359.40
Direct3D API version: 12
Direct3D feature level: 11_0
CUDA Cores: 640
Core clock: 1097 MHz
Memory data rate: 5010 MHz
Memory interface: 128-bit
Memory bandwidth: 80.16 GB/s
Total available graphics memory: 20435 MB

I don’t have that setup but I am running a GeForce card.

To understand this and see if there is anything to be done, I need an example file and instructions to follow to see if I can reproduce the issue.

Here’s a link to upload a big file:
Please include this URL in the upload comments so we know what it refers to:

Hi John,
For me it’s as simple as make a cube, set perspective view to rendered, then full viewport,
When I pan or rotate, the edges of the cube cut apart or become really jagged. Sometimes there is a slash across the whole scene, I have seen this in other 3d apps too so I think it’s an NVidia thing. Can’t send in a screen shot because it only happens when the viewport is active like during a pan or rotate, zoom in and out seems to work well though.
Thanks for replying,

So far I can’t repeat that.
Do you have multiple Rhinos running?
Does Turntable bugger the display for you too?
You said “full viewport”. Do you mean MaxViewport or Fullscreen?

I’m getting a wee bit of edge flickering in Fullscreen and Turntable in a default Rendered display but nothing like you’re describing.

Hi John,
No multiple Rhinos, I only have V6 on this computer.
Not full screen just the full viewport double click on the title, I knew you’d ask this. :slight_smile:
I see there was an update and I am getting better response in the viewport under rendered looks really good now.
However I see what I reported still in my custom View mode, I think it has to do with edge settings and or line work in the viewport so it may happen in rendered mode too. I attached my custom ini, it’s not fancy really a working mode with heavier line weights and edge settings on objects for my tiring eyes.
Thanks for looking,

RMRendered001.ini (9.3 KB)

Your RMRendered001 display mode works fine on this GeForce GT 750M. My drivers are about 9 months old (ver., from Dell for Windows 10.

Oh well doesn’t work here.
Thanks for taking a look.

I have the 970 gtx and have never encountered anything like this with the win 10 drivers.
You can use a screen recording software to capture video like http://camstudio.org/

Do you have a 3d mouse? Try to unload/unplug the 3d mouse (plugin)…

I have two video cards installed in this laptop, one is the intel video card and the other is the 970 GTX. Rhino is using the 970 GTX. Thanks for the link to Camtasia.

Thanks Thomas no 3dmouse here.