(V6) Antialiasing change?

image

At a small zoom, the current view is - horrible.

What computer/monitor combination are you using? I really need to find a system that produces that results that you are seeing.

NVidia 1060
Older i7 (4770?)
LG 43UD79-B

image

image

Which one is the best? (open at 100%)

I should have a new SR8 build available tomorrow that has some changes I made today to try and improve the display.

should have a new SR8 build available tomorrow

Do you mean this one?
(6.8.18211.21311, 30.07.2018)

If so, it is a bit better, but still not ok.

In addition, there are artifacts from the grid now.
Depends on the zoom, sometimes they are there and sometimes not.

Do you have WireThicknessScale set to a value other than 1?

I don’t think that one had my changes in it, but it’s also pretty hard to tell. Here is one that looks like it has my changes
http://files.mcneel.com/dujour/exe/20180801/rhino_en-us_6.8.18213.03201.exe

Steve, no.

Installed the above (6.8.18213.3201, 01.08.2018), and the view is - hmm.
V6:
image
V5 (exactly same conditions):
image


Then I played with the WireScale you mentioned.
0.5 to 0.7 seem to be a bit better, or 1.4.
But the same quality as in V5 can’t be reached.
I switched it back to 1.


In other models than the abc it looks like AA is not doing anything:
image

Those images must be getting scaled because the V6 image looks much better than the V5 one that you posted. Does TestLineSmoothing make any difference in 6.8 for you?

The images I sent are not scaled by me.
Set the browser to 100% or download the images and view them in Photoshop at 100%.

No, no visible difference for me.

I downloaded and looked at them at 100%. The first image which is labeled V6 looks great.

If you think so, I don’t know what to tell further.

1 Like

I believe you that what you are seeing doesn’t look as good to you in V6 as in V5. The screenshots posted in discourse probably don’t tell the true story.

I think I know what’s going on:
image

This is zoomed into the V6 screenshot.
The lines are very good - far better than in V5.
In the curved parts you can see yourself, 1 pixel overshot.

That does not happen in V5:
image

Charles is spot on here Steve. Open both images and compare the top of the “L and V” to each other too. In the image from V5 it looks correct, but in the one from V6 it looks like a “banana”. The “A” pops the other way and the “X” has rounded feet… and for designers that rely on visual evaluation then that just isn’t good since it appears that the curves are wrong. (and the thing that causes these out of place pixles (Just like Charles points out with the “T”) are probably (?) the same thing that causes other strange linedrawing artifacts.)

That said, I agree with you that the V6 image looks better as a first impression!

The model is full of bad made curves.
This is a part of the L:
image

In V6, the opposite of the reality is seen on small zoom scales.

RH-46636 is fixed in the latest Service Release Candidate

@stevebaer

I have found something.
The not-so-good rendering is far better in a perspective viewport.
It seems the overshots do happen when there is a plan view to the cplane.


The perspective viewport is set to parallel projection, but not a plan view.