V5 - STEP surfaces no longer joining on Import?

As title: When I import STEP files into V5, the surfaces no longer join even though I’ve selected the option to do so in the Import dialogue. Is anyone else seeing this problem? I’m not sure when it started doing this - I never used to have the problem but I haven’t used STEP files for a while. It’s happening with files from several different sources, so I think the problem must lie within Rhino.

Hi Matt - there is another aspect to this which is the total number of faces - there is a threshold, set in the import dialog, for ignoring the joining beyond a certain number of faces (as I recall, it was needed in some cases to make the import happen in the users’ lifetime - joining can take a long time, though I think this is all different in V6) Does that setting come into play in your case?

image

-Pascal

Hi Pascal - The files I’m bringing in aren’t large enough to be troubled by that option. They’re typically around 100-200 faces. I’ve been assured by the company that are sending me the files that everything is joined when they import the same file into Alias (they don’t use Rhino much). A lot of the files are legacy data, so I’m unsure of the original software that was used to create them. I’m also not sure if Alias is managing to join everything, while Rhino is failing. That said, I’ve not seen this problem before. Rhino is usually very reliable with STEP imports.

Are there any other options beyond those in the STEP Import dialogue that may affect this?

it will also depend on your absolute tolerance of the file you import in. If you manually join things with JoinEdge you can check the actual difference between edges that you expect to join

Most of the surfaces join manually after import without a problem. On closer inspection however, some of the geometry has been created by lazy modelling; mating edges of joined surfaces look ‘broken’ in wireframe. Subsequent to joining, I’m not getting many naked edges reported though. Perhaps it is something to do with file tolerance. I’ll look into it. Thanks for the suggestion.