V-Ray Next Lights in Nested Blocks

Hi,

is it possible to have eg a “Mesh Light” in a file where I save a model of a tubular light source, that I then insert into a “photostudio” 3DM as nested blocks?

All the regular V-Ray Next materials import correctly, but lights do not.

Perhaps this isn’t supported yet?

Thanks for any cues,
Duncan

Hello, Duncan,

You should have no trouble creating a block out of a Mesh Light, exporting it and subsequently inserting it other projects when using the latest version of V-Ray Next. All of the light properties will be preserved.
Alternatively, you can use V-Ray Emissive materials as well.

Please let me know if you have any further questions!

Kind regards,
Peter

@Peter.Chaushev
I have a lot of issues as well with mesh light and blocks. Some times I’m not able to add mesh light to a block and sometimes when I convert a geometry with a mesh light into a block, the mesh light disappears from the V-Ray UI.
So, working with mesh light and block is not stable enough.

1 Like

Hello, Fernando,

If you are able to reproduce any of the issues you mentioned could you please describe describe them in steps and/or pack and submit any of the block or source files for investigation?

Regards,
Peter

Thank you for getting back Peter.

Sadly I am experiencing the exact same as @fernando_rentas1 describes.

I think I am using the latest V-Ray for Rhino:

1 Like

Hadn’t seen your response in the meantime.

Steps to reproduce:

  • Create a pipe and apply a MeshLight. Save as 3DM.
  • In a new 3DM, insert the pipe-3DM as an active referenced block.

The Mesh Light pipe geometry is showing transparent for me, and the MeshLight isn’t added to the asset manager.

For the time being, I am copy pasting the light as embedded blocks, which works, but isn’t ideal for collaborative workflows.

There are the steps, I could reproduce it all the time.
Steps:

  1. create two object (spheres)
  2. select both spheres and convert them to a block (both object in the same block)
  3. Open V-Ray assets editor and go to the light panel
  4. right click on the light icon and create a mesh light
  5. double click on the block to edit it.
  6. select one of the sphere and assign the mesh light to one of the sphere
  7. close the block

The mesh light will disappear form the UI

Thank you both for your replies!
The issue is now logged. A solution will most likely be available in an update after the upcoming one.

The only workaround I can offer right now is to apply V-Ray Proxy / Mesh Light / Fur / Clipper to an object and only after that set it in a block definition. Having such V-Ray objects created within a block causes them to have all their data deleted upon being edited.

Kind regards,
Peter

I’ve just found out that if you simply add a mesh light with the exact same name as is set inside the linked file, it will then show up correctly for me in the interactive render.

Sadly this issue doesn’t seem to be exclusive to Mesh Lights, as I have the same problem with regular materials being linked over more than 2 levels down… :neutral_face:

Setting blocks to “reference” helps tremendously, and makes sense too when materials are based on layers. In case of “active” blocks I don’t see how it could read the layer materials correctly.