V-Ray Fur too slow

Hello,

Does anyone usually use V-Ray Fur for making grass?

I’m trying because I’m doing some images for a stadium and it is insanely slow or just crashes even with the standard fur settings.

I’m simply applying the fur to a planar surface.

I’ve made some tries and I’m getting a bit desperate, I work in the model in mm, can it have something to do with the scale of the model?

Thank you.

Hi,

I never used fur before but I tested it here. I took a really old scene, so the materials are not working, but I setup a fresh fur material. I think important could be to set a defined polycount for your grass plane if you use the per face mode. But the area mode should work for simple planes too. It looks like the preview at the Rhino viewport seems to show the density of “per face” mode only.

image

Render time is fine in GPU mode based on two 2080ti, CPU mode is fine too (2950x).

You could check the RAM usage during the rendering starts. My scene is in cm, you could try to switch to cm too. This test rendering was done in approx. 1 min.

Screen-Shot%20256

You could try to render your grass plane only and hide all other geometry for testing.

Hi,

Does V-Ray crash on rendering, or you are experiancing slow down with the viewport preview?
The fur preview is indeed slow for large meshes so it has an option to be disabled in the viewport.

That could be the reason. Default settings are wrong.

image

This creates 0,6 grass objects per each mm2. Try to use a relatively small plane, around 1000x1000 mm and then lower the Count to 0,001 and then increase the number slowly if it starts working.

The slowness was not in the viewport, it was on the rendering, in fact it would not render at all.
It was a problem with the scale indeed, and I solved it by scaling the model to cm. Next time I will try to lower the count in the mm model and try to solve as I usually work in mm.
Even tough scalling the model solved the issue the render would crash somewhere on the process, in fact the surface area of fur was quite big, so I had to render the grass separate from the rest of the scene and then use photoshop to bind them both. It took a little bit more time but in the end I got the result that I wanted.

Thanks a lot for your help.

Cheers

To decrease the load on your system during rendering V-Ray Fur be sure to check out its Level of Detail options. Depending on the scene, the same result can be achieved sometimes at a fraction of the initial resource usage.

Kind regards,
Peter

1 Like