UV problem In Beta Mac

I can’t seems to figure out what am I doing wrong here…?
I just need the image [an image] to stick nicely to the front of this mesh.


opal_UV_issue.3dm (4.2 MB)

Thing sort of works ok for other mesh [trying to represent opals with very limited success]

As only the top will be visible, the deformation of the image on the sides is [mostly/hopfuly] not a problem here

Your file does not include the texture.

Sorry I saw there is another texture file included…

One thing you can do is enter the UV Editor and scale / drag the texture islands on your texture image to choose which part of the texture goes where…

Another command which I find useful is _MappingWidget

It shows the texture as a widget in the viewport and you can scale and drag it to where you want it.

opal_UV_issue.3dm (1.4 MB)

Thanks a lot Martin @martinsiegrist

perhaps something is Broken on the Mac side… I can’t seems to get the mapping widget to show…?
It was working a few builds ago.

I also can’t find a way to scale the texture. the size sliders do nothing. Either I’m missing something obvious here, or the thing has been recently broken [on Mac] it is also the beachball that comes up with every move, that makes me think something is bugged.

1 Like

here’s with SubD instead of the mesh, and another larger texture… and a few more hours trying… with 0 progress. How frustrating…

would be great if someone with a Mac [M1/M2] could test if the _MappingWidget thing work on your system…

opalSubD_UV_issue.3dm (1.5 MB)

thanks a lot
Akash

Have you tested QuadRemesh of the SubD and then UVmapping it with the seams out of sight?

Hi
thanks
The original mesh was a perfect symmetrical quad.

And you don’t need to do quad re-mesh on SubD in rhino. directly meshing the subD will result in quad mesh.

Please test this file with you own texture in the DiffuseColor-Channel of the Texture and post the results.
opalSubD_UV_at_Origin_v7.3dm (2.4 MB)

Hi
thanks

Apology but I don’t relay understand how does you file helps here…?
your texture [as visible on my computer] is heavily stretched and polles at the middle of the opal.

As for me, I’m not using a specific texture, just an image from the net. And this is part of the problem, as it is difficult to find a properly hi res large image to use. [I can’t take proper photos now as I’m not in the country where my Opals are stored … ]

  • I managed to put textures on other opals, But this one is not behaving and I don’t know why.

the problem one:

here is one that map ok, [the uneven border is not a problem as it is bellow the setting line.
No stretching, no deformation, no smudging, and no cuts of separate uv islands…
the main difference is that this is a 50% larger image and the source is RAW not internet jpeg. [a real opal that I have back in the studio]

As mentioned earlier: You just need to understand how UV works in Rhino 7 or Rhino 8-Beta (it has changed a lot).

When texturing an organic volume such as your opal, you can choose to place the seamlines at the bottom and back. But you need to take control of it and not rely on the texture-coordinates from Zbrush or Rhino’s own SubD 3D model.

Hi @Erazmataz
thanks.

Can you please verify that at this point [as shown in the screenshot below] it is actually possible to select a mesh?
But can you verify that this is actually woking in Beta on Mac M2/M1 ?

Because here I can’t select the mesh, So how am I supposed to do custom mapping…? move seams and all?
Or is it something else that I’m doing wrong here?

Hi @Akash

You can use the Unwrap command to get continuous texture mapping over the front side of the opal.


Select object, open Object properties panel and Texture Mapping.
Click Unwrap button and accept the Mapping Channel option 1.

Then check the Unwelded Only option to more easily pick the unwelded mesh edges. Double click each mesh edge chain around the back side of the opal - these will be discontinuities in the resulting UV mapping. Once you’re done click Apply.
Now you have set up a texture mapping on the opal that does not have discontinuities on the front side.

Then you need to adjust the mapping to make it work better with the bitmap texture. So open UVEditor (there’s an icon on the Texture Mapping panel near the Unwrap button, or you can type in to comman prompt UVEditor). The larger of the islands is the front side of the opal. Use gumall to move and resize it so that it is covered by the useful area of the bitmap. Once ready, close the UV Editor window.

You can run the UV Editor again to adjust how the image appears. Or you can run Unwrap again if you think there’s a better way to select the seams.

1 Like

Hi Akash. I don’t work for McNeel and I have no access to Apple Silicon, so I can only suggest you watch Brian James’ (UV Unwrap) video, since they explain very nicely the workflow in Rhino 8 Beta. - But I expect it to be the same on Windows and on macOS, since the UI in Rhino 8 Beta is close to identical.
First you need to get rid of any UV-mapping from ZBrush. Second you need to select your seamlines. Third you need to orient your RenderMesh how you would like it in the “flattened UV editor”. Then you are done and ANY texture can then be applied very easily. Check this video to see an example:

1 Like

Thanks a lot @Jussi_Aaltonen
this is working fine here following your clear instruction
[almost]…
*image from before adjusting the texture
the unwelded only check box is missing in the floating command option

I May need to split the opal anyway in order to assign a different material to the back side,… or perhaps Nurbs it and assign per face…

It is only visible when Unwrapping mesh objects. Is your object mesh or SubD?

Ok thanks
Yes it’s a SubD