UV-Editor keeps creating geometry in the mesh that I can't mess with

It’s been a minute since using rhino for rendering. Keep that in mind.

I am about to start a new job as an architectural drafter. My background is in Furniture Design. I wanted to wow the boss so I asked for a model to tinker with. He sent me a model with a parking lot, which is the topic of my post. I’m rendering for fun on this.

My intention here is to get a decent, non-repetitive asphalt texture. What is the best way to remove these random vectors that keep showing up in my UV-Editor and messing with the look of the asphalt?

I don’t know what else to include. I’ll be happy to answer any other questions.

Fig 1: Shape of parking lot with start/end of an open curve ends in the End Analysis. I used black paint for visibility.

Fig 2: Use Texture enabled in UV-Editor

Fig 3: Ashphalt texture applied, and Use Material enabled in UV editor

Fig 4: UV mesh scaled lager than in previous figures.

Can you post the object in question by selecting it and using the Export command to save only that selection as it’s own 3dm file? From your screenshots everything looks like it’s working and that you have used either a Planar mapping method or used the Surface UVs. I can’t tell what the geometry you don’t expect or want in the UVeditor is though.