UV created on an Angle when using planar srf

Hi Rhino’s
I am having an issue when i create a planar srf, the UV is on an angle which is messing me up for later stages in the model. screenshot attached showing

Hi @Graz,

to control the isocurve direction you might create a surface yourself using _Plane command with _Center option. Enter 0 when it asks for the center point. Finally trim the plane with your boundary curve.