Using smash command to prepare for laser cut, output isn't correct shape

Hi everyone,

So I’ve modeled a mesh lampshade, and I am using the smash command to turn it into a flattened version of the form for lasercutting. The lampshade is below.

Upon using the smash command, the output is this:

Although the command outputs the holes and general form correctly, it doesn’t seem to take into account the way that the mesh bends along the two bottom edges. Due to the way that the mesh bends, the edges that it bends along must be longer in length to account for the shortening that occurs during bending. The smashed output is basically a rectangle, and this means that upon laser cutting and bending, the bottom edges will be shorter than the top section of the form.

I was wondering if anyone knew how to fix this problem, or perhaps suggest a different command or technique to produce the result that I am looking for?

On the right side of your flattened image I see a concave curve, which means the middle is shorter. Apparently this only happened on that one end, so the hole pattern doesn’t match from one side to the other.

hi @Jamie_Matthews did this help you at all? there are so many threads in here where people asked questions and never cared to give a peep if it worked, just wondering

Hey, the concave curve on the right side is actually from the lines that I used to loft the original form. This was a draft version, so the lines along the two bottom edges are slightly out of alignment with the top portion of the shape. The curves are still ignored, which is frustrating.

Hi @RichardZ,

Although your comment was helpful and I appreciated it, it wasn’t exactly what I was looking for so I ended up using a grasshopper definition to achieve the placement of the holes along the surface :slight_smile:

ok, thanks for letting me know :wink: whats your lamp made off? just thinking must be a strong laser cutter if its anything out of aluminium or is it milky acrylate? led, fluorescent? i love lamps cool design.

you could drop in the smashed output and somebody could have a look maybe something like flow onto a new rectangular surface might do just guessing for now.

You might try the Squish command instead of Smash. Squish allows for control of how the flattening happens.


Hey @davidcockey , thanks for your reply.

I’ve remodelling my form and have finally gotten around to trying to flatten it again. Ive tried to use the squish command but cant seem to wrap my head around it. I’ve changed the settings, use the curves of the form to create the squish, and tried a few different things, but each time I end up with the same result, which is the form flattened as though you were to use a hydraulic press from a side view of it (no screenshots atm, can potentially link later), but I was wondering if you could potentially help me out with this?

Thanks in advance

@Jamie_Matthews How will the shade be shaped from the laser cut blank? The material has to stretch and/or compress.