Using Rhino for computing hydrostatics

I am trying to compute some properties of a sailboat hull using the hydrostatics mass analysis tool. The model is well-formed. I am running into a problem in that all I get is wetted surface with water plane = 0. None of the other measures (center of buoyancy, etc.) that hydro is supposed to compute are computed. I am somewhat new to rhino, so may be doing something stupid. Has anyone had experience working with the hydro analysis tool in Rhino?

Hello - please post a simple file that shows the problem - if it is confidential, please send to and include a link back to this topic in your comments.

I see your post to tech - just need a file, I do not see one attached there.
OK, got it…

@keydelsmi Join all the surfaces first.


You probably have a naked edge below your intended waterplane. Why do you think they use the term ‘watertight’ edges when talking about polysurfaces. I was just starting a sailboat project and was just about to run my ORCA hydro for an initial look at those stats but thought I would do so in the native Rhino command and came up with these results.

I don’t even get results shown beyond wetted surface=220 and water plane=0. The other results just don’t show (your example at least shows those results). I’m wondering whether I’m doing something dumb. When I pre-select the hull before invoking hydro, it becomes de-selected when I enter hydro. When in hydro, I get the deficient results pane immediately after selecting a contour from hydro.

Hello - select all the surfaces, Join, then run the hydrostatics.
Any better?


Thanks for your suggestion. Unfortunately I get the same partial results pane. Wetted surface is non zero, water pane is zero, and no other results show.

Hm - here is what I see in the ‘original’ file:



Are you seeing this in the jpg that I sent out???
That is really strange, because that’s not what I see at all.

Did you compute from the CAD model that I sent to tech support earlier?

Hello - yes - two cal30 models? if there is another file, I did not see it.
Make sure all the surfaces are joined into one polysurface. There should only be a naked edge(s) at the top. (ShowEdges command)

Can you run SystemInfo in Rhino and post the results?


your results look absolutely reasonable.
Are you running on a mac or windows?
this is what I get when I run after join using the “original” model.

How do I run system info in Rhino? (sorry, newbie here)

Ah, this is mac… let me try over there.
SystemInfo is a command - type it or find it in the Tools toolbar.

I get the same results as on Windows.
I get what you get if not all 4 of the surfaces are selected for the Join.


Found the system info command.
Here are screen shots

… Had to do in 2 parts. The bottom shows on top here.

I will do it again. I selected all four before (I thought).

I get the same thing as I got before after selecting all four surfaces and joining.
One question: when I invoke hydro there is a dialogue box asking me to select hydro options (this is different from specifying the waterline height, the long. axis and symmetry). I’ve left that blank-- not knowing what to put in to get the full computation. Should I be putting something in there?

here is the dialogue asking for options

Ah — 4.5 for the waterline is above the model… your units are feet.


well, this is interesting. Before the join, the world origin (z=0) was at the base of the keel, and the waterline was at 4.5. Now after the doing the waterline is at z=0.
When I set that I get REASONABLE results being computed. Thank you so much for your help!

I recommend ORCA as the best hydrostatic plug-in; been using it with great success for years.