There are two kinds user text commands. GetUserText and SetUserText manipulate text attached to objects. GetDocumentUserText, SetDocumentUserText, and DocumentText manipulate text attached to Rhino 3dm file. I believe that most of these commands should be renamed: GetUserText = GetObjectText; SetUserText = SetObjectText; GetDocumentUserText = GetDocumentText, SetDocumentUserText = SetDocumentText.
I would agree that the term “user” in the command names is not really explicit and could lead to confusion. ObjectText and DocumentText seem more direct and understandable.