Updating embedding URLs taking long

I just added a new URL to a model to allow embedding it in an iframe. But the viewer keeps saying “embedding not allowed for…”.

How long does it take to update? Shouldn’t it be pretty instant?

Or what else might be going wrong?

In my model in shapediver:

It takes a while to apply this global setting to all models at the moment. We will improve this in the future, but for the time being, what you can do is go to the model edit page and change any other setting, then save it. At the same time, the new domain will be whitelisted for this model.

Thanks @mathieu1, I tried updating a setting and have also waited now for an hour, but its still not working.

What else can I do?

Did you try adding www.monulith.com instead of monulith.com in the list?

Yes, that together with updating the model again, solved it. But specifying monulith.com should include all subdomains as well or do we have to add “*.monulith.com” then? It’s especially weird since the domain we are using and is the default is without the www.

image

why would it then try to access from www.monulith.com? That doesn’t really make sense.