Update page error and crash bug


#1

Hi @pascal,

in the below dialog for updates, i´m facing an error message when i click on “check now”:

this is the error message:

once i click on the link for “learn more about usage statistics” rhino crashes immediately with the crash report dialog. (This still lists Rhino4 but i´m using Rhino5 x64). I´ve sent the crash report along with an empty file :wink:

thanks,
c.


#2

Odd, both of those are working here, just tested… Wonder if it has something to do with system language?

–Mitch


#3

Hi Mitch,

don`t know, btw. the email adress field i´ve cleared only in the screenshot. Maybe it has something to do with my security setting but both are repeatable.

c.


(Pascal Golay) #4

@brian, do you have an idea?

thanks,

-Pascal


(Brian Gillespie) #5

If Google Translate got it right, “Der angegebenen Datei ist keine
Anwendung zugeordnet.” translates roughly to “The specified file has no
associated application.”

Both of those links try to open a web page by passing the full URL to the
operating system. This causes the page to open in your default web browser

  • but it appears that you don’t have a default web browser.

My guess is that your copy of Windows doesn’t know how to open an
http://url. Here’s how to fix it:

  1. From the Start menu, click Default Programs
  2. Click “Associate a file type or protocol with a program”
  3. Scroll down to “HTTP”, and select it
  4. Click the Change program… button
  5. Select your favorite web browser

Does that make it work?

  • Brian

Brian Gillespie
Rhinoceros Development
Robert McNeel & Associates


#6

Hi Brian,

thanks for your help. But i am sorry, in that list i do not have HTTP, neither unter extensions nor under protocols.

is there a way to add it manually ?

thanks,
c.

EDIT: I fixed it by clicking the button in firefox to set it as default browser. It now opens the url fine and lists HTTP under protocolls once that dialog is re-opened. Thanks !


(Brian Gillespie) #7

You might try installing (or reinstalling) a web browser. Clearly you’ve got one - you can read this forum.

But right now your question is about how to make Windows work properly, which is a good question for Microsoft support.

To see what I mean:

  1. From the Start menu, type cmd and press Enter
  2. In the command prompt, type start “” “http://www.microsoft.com and press Enter.

Your default browser should open. If it doesn’t, then your computer is misconfigured.


#8

thanks brian, the two links in options page work.

c.