Unnecessary selection menu

Not sure what setting I’ve managed to change, but I’ve been seeing this a lot lately, even when there shouldn’t be any question regarding what I clicked (because I clicked in the middle of the hinge, nowhere near the underlying surface objects):

Anyone know how to stop this menu from popping up so often?

(And I don’t mean “at all”, because it’s very useful when you click too close to another object. This behavior is relatively new, so I must have changed something, but what?)

Hello- can you see if this behavior persists in a similar view that has a parallel projection?


I’ve never used parallel projection in Rhino, so that can’t be what has changed. But I did test it just now (using the “toggle view projection” toolbar button) and it didn’t make a difference.

The menu pops up 75% of the time as soon as there’s two objects on top of each other, thick or thin. If the two objects are within 5cm or so from where I clicked the mouse, the menu pops up 100%…

There must be a setting that adjusts what Rhino considers to be an ambiguous click?

Hi Robert - do you also see that when you make 2 boxes in a new file from a factory-default template?

Hi, when I make 2 boxes in a new file, and place them pretty close together, things behave normally.

The problem arises when I add a third box that is significantly larger than the other two:

That’s essentially what caused my original post: The hinge in the screenshot is about 8cm long while deck underneath it is about 8 meters long…

Oh… I wonder if it has anything to do with this:

And in turn, with this

Yeah - that is why I asked about the parallel view - your screen shot looks like you’re very close in in a relatively large scene - in perspective, depth testing may be too coarse in that situation, but a parallel projection may be fine.


I’m still hoping it has something to do with this:

@pascal @wim as you can see in my updated screenshot, there are no longer any bad objects and if I select all, the gumbal scaling indicator do not extend further out than my objects:


All layers have been unhidden as well. What causes the Zoom All Extents to behave like this?

What happens if you select all the objects and ShrinkTrimmedSrf? Can we get the file (tech@mcneel.com) ?


It’s an almost entirely complete assembly of the latest boat our sister company is launching, so I don’t think my bosses will be comfortable in sharing that file right now. :slight_smile:

However, here’s what I found:

  • Shrink trimmed surfaces did indeed work, thank you for that tip!
  • Selectively deleting each layer from the file to find the problem object did not work.

I’m guessing the reason for the second option not working is because the block definition still holds the problematic objects?

Anyway, this made me think, all of the surfaces in this file are imported from Catia/Nx, which often leaves a bit of padding when it auto-trims surfaces (for fillets, etc). Would it be an idea to also have a padding option for the ShrinkTrimmedSrf command?

EDIT: The selection menu seems to be back to normal operation now! :+1:

Hello - ShrinkTrimmedSrf does leave a 1% (I think it is) padding on the underyling surface if the trim is not an isocurve.