Unlocking STL import settings for Mac


#1

I set the weld angle too high on my import settings. Unfortunately, I checked “do this every time”. I can not remember how to undo it so it asks the weld angle when I import again.


(Pascal Golay) #2

In theory, it looks like, there is meant to be an Options button as in Windows, but I do not see it so far… the process looks broken to me.

@BrianJ, am I missing something, oh mac user?

-Pascal


#3

Thanks for the reply. i had done this in the past and was able to fix it… I believe there is something broken. Could be me though…


(Tim Hemmelman) #4

In the windows app there are test commands (for plugins that support it) that are hooked up to the options button on the file i/o dialog. That’s not hooked up on the mac side yet (maybe it won’t ever be, I don’t know how hard it is to hook it up) but you can run the commands manually so you can uncheck the “don’t show this dialog” option. For STL it’s called STLImportOptionsDialog. All of them are similar so you can try substituting STL for the file extension of your choice.


#5

Thank you Tim!