Units change warning doesn't appear if no objects are visible

  • Open a blank file using mm small template.
  • Draw a square 100 x 100 on a visible layer
  • Go to DocProperties>Units and change the unit to meters and OK.
  • You get the following dialog:

Note the first option (change unit system only) is activated.

Hit CANCEL.

  • Now, turn off the layer the square is on (there should be nothing left visible).
  • Go back to DocProperties>Units and change the unit to meters and OK.
  • No dialog shows up.

Turn on the layer with the square. The file will have changed to meters units and the square will measure 100 meters. The file unit change was applied without asking the user which option to choose.

Thanks.
https://mcneel.myjetbrains.com/youtrack/issue/RH-79579/Units-change-warning-doesnt-appear-if-no-objects-are-visible