Unhandled Exception at startup Rhino 5 (x64) (Win7)

Recently I have been experiencing an Unhandled Exception when starting Rhino 5 64 bit (Educational version) on Windows 7.

The Exception is harmless since I am given the chance to continue and everything works fine. However when trying to debug my custom plugin for Grasshopper Visual Studio breaks on this exception, so I can’t debug.

I have tried to reinstall Rhino but with no results also I have tried turning off all loaded rhino plugins (those who ship with and don’t ship with Rhino) but nothing so far.

Below is the exception detail given by the pop-up window and from the VS debugger.

Any ideas are most welcome.



************** Exception Text **************
System.FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
at System.String.Format(IFormatProvider provider, String format, Object[] args)
at RhinoSplash.LicensePanel.Init()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.SetVisibleCore(Boolean value)
at RhinoSplash.Splash.TabActivated(Object sender, TabActivatedEventArgs e)
at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
at RhinoSplash.TabPanel.set_ActiveTab(Tabs value)
at RhinoSplash.Splash.Splash_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at RhinoSplash.Splash.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

From my Visual Studio debugger:

System.FormatException was unhandled
Message=Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
at UnhandledExceptionLogger.UnhandledDomainException(Object sender, UnhandledExceptionEventArgs args)

Thanks Dion, @brian, this looks like a bug in the RhinoSplash project. I added this as an issue to our bugtracker to try and figure out what the possible cause could be

Thanks for the quick reply Steve.

If there are any developments on this bug please let me know.



From the stack trace that you posted it looks like something is happening in the splash screen code on your computer so disabling plug-ins shouldn’t really have an effect.

Yeah I figured that as well. The thing is that it started this afternoon
out of the blue. I had been developing my plugin for Grasshopper the whole
day (running Rhino and Grasshopper in debug mode) and suddenly this pops

I haven’t been updating or installing anything in the meantime so it makes
no sense to me that Rhino suddenly has a bug in the splash screen.

Please let me know if anything comes up.


Just an idea: if you start debugging with the /nosplash argument (set this in the start up parameters in Visual Studio), does the exception go away? That will at least enable you to keep working.

That did it for me, thanks for the suggestion Menno!

Just out of curiosity; there a way to suppress the splash screen also when
I just start Rhino normally? Not that it is such a big deal, but it would
be nice to not see that message every time I start Rhino.

Thanks again for the input guys, now I can get back to work :slight_smile:

You can also add the start up argument /nosplash to the shortcut definition used to start the program.

Is it possible for a plugin to suppress the splash screen?

or a rhinoform to open:

Process.Start(rhinofile, “/nosplash”)? works if I directly link rhino but not a 3dm file.

nvm found the solution:

Process.Start(“C:\Program Files (x86)\Rhinoceros 5\System\Rhino4.exe”, "/nosplash " & rhinofile)

I believe this exception was fixed in Rhino 5 SR8.

Hi, having issues similar to Rhino 5 on Windows 10. The exe shows up in my task manager but no UI, and I can’t even end the task in the manager either.

And when it does show it, it crashes and then when it prompts debugging, crashes again?

The only thing I was able to scrape from the one time I was able to even get something, I got this:

Unhandled exception at 0x69031A8D (clr.dll) in Rhino4.exe: 0xC0000005: Access violation writing location 0x01C001BC.

I’ve been trying to replicate it, but it’s back to just running the exe but no UI…