Unexpected outputs of Wallacei integrated with Termite nest

Hello!
Thank you for the great plugin.
Recently, I’ve encountered a problem of mismatching the outputs of Wallacei with the outputs of another plugin I use. . Actually what I intend to do is Space planning by integrating a plugin called “Termite nest” and Wallacei. The problem is that the output layouts of Termite nest are not unique (same input variables, give different outputs) it seems it changes the seed automatically. So I’ve noticed that none of the phenotypes corresponds to its relative fitness values (the genomes that already have been used in the simulation step are useless as they give different layouts when I want to create the Phenotypes.
So what I did, was that I used a data recorder to record all output layouts when Wallacei was doing the simulation (I did it with 5 generations 5*5) and then I checked correspondences of fitness values to the recorded layouts but I’ve noticed that just the first generation (0) matches to its relative layouts, while the rest of generation are completely irrelative with the recorded Layouts.
I have no idea what is going on behind the simulation.
Any little help will be appreciated
Thanks in advance

Firts of all i think it will be more helpful if you could share some files and screenshots. I can have a look from my end. Also Can you constrain the seed value of Termite Nest component? As far as I remember it is written in python and you can double click on the component and access some parts of its methods.

I appreciate your quick response, thank you!
Unfortunately the scripts of Termite nest components are not accessible.
Here there are the files.
Thank you again for dedicating time.
MOO_F3.gh (1.2 MB)
Relations.csv (183 Bytes)

I’m still looking for some feedback on this question. Is anyone able to provide any insights or advice?

I try to go over it in the coming days

Dear Milad
Thank you very much for dedicating time. I appreciate it.

I tried to open your file and as usual there are loads of plugins I don’t have here. I managed to have them all installed except the SpaceSyntaxDesign_GH. I thought this would be Syntactic by Pirouz but apparently this is something else. I can not run your file without this plugin.

Dear Milad, I’m sorry for the inconvenience caused by the unknown plugins. I’ve refined the file by removing unnecessary parts. Could you please try this new version and let me know if it resolves the issue? Any feedback is appreciated. Thank you for your help.
MOO_F3_B.gh (1.2 MB)

I highly apologize for writing about this issue again, Unfortunately despite so many attempts, I can’t still find a solution. I tried to refine the file still more. Is anyone able to provide any insights or advice?
MOO_F3_C.gh (1.2 MB)
Relations.csv (183 Bytes)