Undo in WIP 8.0

Have a Python script that runs in Rhino 7 and the undo will take me back to where I started which is what one would expect, but when I run the same script in WIP 8.0 this does not happen in WIP 8.0 Rhino just stops responding and does nothing.

Hi @RogerD does this happen with all your scripts? If not, then it would be very helpful if you can send the script in question that shows this behavior.
I could not repeat this behavior on my end.

Some additional info that can be helpful:

-the result of your _SystemInfo
-how are you running the script (through RhinoCode, PythonEditor, RunPythonScript)

I will check if all my scripts have this problem or just the one I was working with.

Hi Roger,

I was looking at the script and file you sent. After I select the red layers in the second step, the script stops at this line, so I suspect I’m missing some info in the file:

Message: Object reference not set to an instance of an object.

  line 248, in GeoMovePoints, "Geo Move Points 8-9.py"

Hi Gijs,

After the red layers have been selected then you should get the opportunity to select each of the layers called “Surface” the script runs here and I think everything you should need is in the Rhino file I sent, nothing external that I can think of.

Try it in Rhino 7 as it was written for that.

Is it possible that you are calling a method that has been changed from Rhino 7 to Rhino 8? On or around line 248?

I was running it in V7 already. But it happens in both v7 and v8. Can you verify the file and script in the link you sent to me or send me the one that works on your end again?

To be more specific, your script is requesting some user texts, and the first object it fails on only has these two:

['Point Layer', 'Group']

Hi Gijs,

I must apologise I sent the wrong script file , I sent version 8-9 not version 9-, if you change the file extension back to py then I hope the attached will work for you.

Once again very sorry for the mistake.

Geo Move Points 9-8.txt (36.2 KB)

Hi @RogerD n/p

I just ran in both v7 and v8 and here all works as expected and the same. It takes just a few seconds to execute and undo, whereas the performance of your computer in the video seemed slow.
pls run _SystemInfo in V8 and post back the results

Hi Gijs,

My laptop ran slower than usual when recording the video. Glad it undid alright I will try again tomorrow and see what I now get .

Rogers System Info.txt (3.13 KB)

@RogerD The drivers are quite old, it’s highly recommended to keep these up to date. Furthermore, 2GB of video ram is less than recommended to run Rhino 8

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 1-21-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro K1100M (NVidia) Memory: 2GB, Driver date: 6-14-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 427.48
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

Hi Gijs,

When I check for drivers with Intel I’m told I should get the driver from Lenovo and when I check with Lenovo then no drivers are out of date.

As for Nvidia drivers they discontinued the specific graphics I have installed so no support.

Not sure what if any options I have, but as I’m retiring in 11 months I’m not too bothered I can always use V7 up to the end.

I looked up your card and it says it supports OpenGL 4.3. One last thing you can try is lower the slider in OpenGL settings one step.

Thanks for the info Gijs

@RogerD I have updated Intel drivers using the drivers from the Intel website rather than from the computer vendor.

Thanks David I will give it a try