Undo command acting up

After about 3 undo commands (ctrl-z) in a row the command line starts a search for commands with a Z vs running the undo command. This is only happening with separate (ctrl-z) actions. The undo command will run cleanly if I press and hold (ctrl-z) however I usually end up going past where I want to be and have to Redo.

I have tried several keyboards and turned off sticky keys in windows. Also, there is plenty of memory to be spared so it is not the memory in the options - general.

might be a bug might be user error

Version 7 SR11
(7.11.21293.9001, 2021-10-20)

I can’t say I have been able to reproduce this. Maybe when you press ctrlz quickly you lift the finger from the ctrl before you press the z?

When doing multiple undos, do you tend to hold the ctrl and then press z as many times as you want to undo?

@nathanletwory I tend to hold ctrl and then press z as many times as needed to get to where I want to be.

I can say this has only been an issue with the latest update that was pushed.

I tested that earlier today as well, but was not able to reproduce the behavior you mentioned. I have to say though that I am on the latest service release candidate for 7.12. Maybe you can switch to that to see if that helps in your case: Help > Check for updates…, change frequency from service release to service release candidate.

Hello - I cannot reproduce this either. @tommyp - can you run the SystemInfo command in Rhino and copy/paste the results here? I’m wondering about a plug-in, maybe.
-Pascal

@nathanletwory I will give the 7.12 a try, thanks for the investigation

@pascal

Rhino 7 SR11 2021-10-20 (Rhino 7, 7.11.21293.09001, Git hash:master @ 972ac562128b307e99f15e56dd11586c73e91ecb)
License type: Commercial, build 2021-10-20
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [93% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 10-19-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2
Primary OpenGL: NVIDIA Quadro T2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 10-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.39
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-13-2021
Driver Version: 30.0.14.7239
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\tprewitt\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot10RhinoPlugin (ccedd9da-83b9-429a-aec5-8ec90b85fe67)\1.2.0.0\KeyShot10RhinoPlugin\Rhino 7\KeyShot10RhinoPlugin.rhp “KeyShot10RhinoPlugin” 1.2.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hm - it seems very unlikely that the keyshot plug-in is invloved but just to eliminate that possibility, try disabling that in Options > Plug-ins page (close and restart Rhino) and see if it makes any difference.

-Pascal

Updated to 7.12.21299.13001 and removed the Keyshot plugin however I am still getting the hang-up. Also switched to a wired keyboard just to remove extra variables.

I will try a complete computer restart soon and test on a different .3dm file to see if it is file specific maybe.

Hm - So, it is not recognizing the Ctrl key being down at all, is the problem, correct?

-Pascal

Yes at the core of it that is the issue.

I must then hit escape to exit the search drop down and press control again and tap z as needed.

Also seeing the same thing on 7.11.21285.13001, 2021-10-12. It doesn’t seem to matter if keeping Ctrl down the entire time and repeating the Z press, or Ctrl + Z then up and Ctrl + Z again.

I’ll try again on the latest in a bit.

Sam

Hm - I cannot make it happen with that build either - do you see it right away or after Rhino has been open for a while doing stuff?

-Pascal

In my case, it has been consistent from start up on.

@tommyp Do you happen to have the NamedCPlane panel visible when you run into this? Over here, I am seeing the bad undo behavior when I have that panel visible, but if I hide it behind another tab (still open, but not visible), things get better.

1 Like

Actually yes I have that panel docked in the UI hmmmm I’ll give it a try with it undocked and turned off.

@SamPage I think that might have solved it! I undocked it and closed the panel and the commands seem to be flowing nicely.

When I bring up the NamedCPlane panel it starts getting hung up again.

1 Like

@SamPage - thanks for tracking that down, I’ll test.
Yep, got it, thanks.
RH-66131 NamedCPlanes: interferes with Undo

-Pascal

2 Likes