Undo Bug -- "Undo Typing"

Hi,

Every now and then, for reasons I can’t explain, my undo button will stop working. When I go to Edit > Undo (command), it says ‘Undo Typing’. This happens when ‘typing’ wasn’t my last command…

So, to work around it, I have to ‘Undo Multiple…’ and select which commands I want to undo manually.

The bug disappears when I restart Rhino. But it happens at least once a day. Very frustrating as it interrupts my workflow.

Bug fix please!

This is still happening to me. Can it please be flagged as a Bug?

Hi Gabrielle -

We’ll need a way to reproduce what you are seeing. For starters, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Great thanks, I’ll do it next time it occurs.

Hi Gabrielle -

There’s no need to wait - that behavior is unlikely to affect the SystemInfo report.
-wim

Note that I get this fairly often for no reason I can fathom… on my iPad. Nothing to do with Rhino in my case. This is the first report I’ve seen of it here, so I wonder if this is some kind of Mac system quirk.

Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15002, Git hash:master @ 190335c3fb65efe86c302714a8959a7dadfe667b)
License type: Commercial, build 2021-08-10
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 11.4 (Build 20F71) (Physical RAM: 16Gb)
Mac Model Identifier: iMac18,3
Language: en-AU (MacOS default)

AMD Radeon Pro 575 OpenGL Engine (OpenGL ver:4.1 ATI-4.5.14)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 575
Displays: iMac (217dpi 2x)

Graphics processors
Radeon Pro 575 (4 GB)
iMac (2560 x 1440)

USB devices
Apple Inc.: iPad
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Beats Electronics: Powerbeats Pro Case
Logitech: USB Receiver
Western Digital: My Passport 0748

Bluetooth devices
Broadcom: Magic Keyboard with Numeric Keypad
Apple: Handsfree, SPP Server, AVRCP Controller, AAP Server, Audio Sink, AVRCP Target

Third party kernel extensions
None

Third party plugins
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftOSLog.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswiftAppKit.dylib
/usr/lib/swift/libswiftCloudKit.dylib
/usr/lib/swift/libswiftContacts.dylib
/usr/lib/swift/libswiftCoreData.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino
/Users/gabriellecarey/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Vectorize.rhp “Vectorize” 7.0.7853.17670

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.9.21222.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoBonusTools.rhp “Rhino Bonus Tools” 7.9.21222.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.9.21222.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.9.21222.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.9.21222.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.9.21222.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.9.21222.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.9.21222.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.9.21222.15002

That is a completely different issue… on your ipad/iphone you must have an option enabled in settings called ‘Shake to Undo’. When you shake your device it will offer to undo.

This is not the same. But hopefully I’ve just fixed your problem! haha

Hmm, OK, sounds like a shaky proposition to me… :stuck_out_tongue_winking_eye:

1 Like

Hi Gabrielle -
Thanks for the SystemInfo data - that appears to be all good.
I haven’t seen other reports of this behavior and so we will need steps to reproduce this.
When this happens again, please copy the command history and post that here. Also try to see if you can discern a pattern in what leads up to this behavior.
-wim

1 Like

Will do!

I’m also getting this bug. I am using linear dimensions that I have edited the text to. I’m not sure if this is related, but the undo typing bug is exactly what I see. It’s actually breaking and I have to restart (go ahead and create something without Undo, good luck :slight_smile: )

I tried to reproduce this today and I couldn’t. I think this is just a question of figuring out the particular sequence of events because I suspect I know what causes this. I think it’s caused by a multi-line textfield somewhere that allows you to “Undo Typing” that gets pushed onto the Undo stack and stays there when it shouldn’t. But I can’t figure out the steps.

A good example of such an multiline field is the Text command. So, if you type some lines like this in the text area…

…you get Undo Typing at the top of the Undo stack. However, I can’t get it stuck there. If I exit out of this dialog, it’s off the stack and the previous command comes to the top.

I tried with Dim and Leader to get this, but also failed.

Please keep an eye out if you see specific set of steps to trigger it.