Unable to turn off multiline data in panel

I’m trying to export a panel as a txt file to use in a spreadsheet (google sheets), but I can’t uncheck multiline data in the panel. When I stream contents the txt file follows the same format and when I import that into the spreadsheet it doesn’t format as it should.
Sorry if it’s something stupid I’m a bit of a beginner with GH.
Thanks, Tevitaking street map.3dm (3.0 MB)
king street map.gh (19.4 KB)

Hi -

Just a few general comments to start with:
You uploaded both your gh and 3dm file. That is fine but the better way is to internalize the one curve in the Curve parameter in the Grasshopper graph. That way (1) people don’t have to download and deal with two separate files and (2) you don’t run the risk of the 3dm file being from a Rhino version that your audience hasn’t upgraded to.

More critical is that you are using a plug-in that few people use and you are therefore limiting the help that you can get. On top of that, even if people have installed the ELK plug-in, they won’t be able to provide more than general advice since you are referencing an *.osm file that is somewhere on your machine:
Skjermbilde 2021-09-07 kl. 09.57.33

To get better help, save a copy of your graph and internalize the output of the CustomElkOSMKeySearcher components in the downstream Concatenate components. Then you can delete all upstream components and people will have the same data that you have.

Then, to the specific question: you can only uncheck/uncheck multiline data in a panel if that panel is used as input. When you feed a data tree to that panel, the panel needs to have that structure.

Finally, you might need to be more specific as to how you want the data to be formatted. It’s clear that you don’t want it the way it’s currently formatted but not clear how it should be.

Yeah sorry I read about that in the help us post in the forum but was a little confused, I’ll figure out how to do that properly. I figured out the issue with what you said about the output panel having the structure according to its input, all the panels which were in inputs had multiline data checked so unchecking them fixed it.
Thanks heaps, Tevita

1 Like