Unable to trim a mesh using an extrusion

Dear all,

I’ve been searching through the forum, but I was not able to find a solution or my problem. I am trying to trim/cut a mesh created with a structured light scanner using an extrusion, but nothing happens. I’ve tried with .obj, .ply and .stl files, and nothing. I attach an image.
Sin%20t%C3%ADtulo-2

Thanks in advance.

Hi,
have you tried capping that extrusion? That way you can try a trim with a closed mesh

Hello - use MeshTrim - this may or may not work - Rhino’s mesh intersection tools are not all that robust and the mesh looks like it might be messy, but try it…

-Pascal

Hi!
I capped the extrusion, but it did not work.

Hi!
I’ve already tried several times MeshTrim, but nothing happened. I’ve checked the mesh with MeshRepair, and no errors were found, so I am a bit stuck here :frowning:

Hello - the V7 WIP has some improvements in mesh intersections, you might want to check that - you can also send us the file - tech@mcneel.com - with a link back to this thread - I’ll take a look.

https://www.rhino3d.com/download/rhino/wip

-Pascal

I always use a curve to Meshtrim or Meshsplit for meshes and in most cases it works well.

1 Like

Yes i agrea triming with a curve is a solution i often use in triming/spliting operation, when it don’t work with solid.
(and the unclosed part of the curve made from intersections will show you where the problem is.)

Sylvain

Thanks for your answers, but did not work neither :frowning: I’ve tried that before the extrusion.

Hi Pascal, for the trim, which is better, OBJ, STL or PLY? Can I use the V7 WIP with my previous Rhincoeros license, or do I need a new one?

Thanks,

Verónica

Rhino is notoriusly bad at trimming meshes. It’s as simple as that. But you can Try SplitDisjonedMesh first and then use what I think is named CullDegenerateMeshFaces before splitting. And then if that fails reducemesh a few percent just to rebuild it.

Disjoined meshes are one of the biggest troublemakers for Rhino’s meshsplit so seperating them into parts allways helps, and I can see that there are some small parts in your file.

Good luck!

1 Like

Hi Verónica - from the screenshot in your first post, it looks like you are using Rhino 5. You would have to upgrade to Rhino 6 to be able to use the Rhino 7 WIP.

If your mesh doesn’t contain more than 1 million vertices, you can turn on its points. When you’ve done that, you can just select (with SelBoundary, Lasso, …) points to the outside of your extrusion and simply delete those. (Rhino 6 doesn’t have the 1 million vertices limitation).
-wim