Unable to Snap to Grid

I can open Rhino 7 and it snaps to grid


when I try the same using Rhino.Inside Revit it does not…?
Any idea why? is it a bug or I am missing sth…


I updated to the latest version and it works now…

1 Like

I have updated to all of the latest releases of Rhino, Rhino Inside and Revit and I am still having a snapping issue while using Rhino Inside of Revit. Stand-alone Rhino 7 is working as excepted.


Hi @cgrammens,

It’s working but I guess the default value is too small.
Now it is something near a mm. (1/16" or 1mm.)
I changed the default value to be 3’ or 1m.

This value is saved per construction plane in Rhino.
You can adjust it or open a template with a more reasonable value.

Thx, @kike

I just started a metric architecture prjoect in mm but did not realize the default template for mm in Rhino.Inside had the snap spacing set to 1 mm. Changing the grid snap setting made it easier to work with and not force you to zoom in so far to get a snap. Could it be possible to have the Large millimeter template as the default when launching Rhino Inside Revit? Thx again.

Sure, it will be like this on the next release.