Unable to preselct object for WireCut


I am trying to invoke the WireCut command from a C# program. Before I run the WireCut script, I pre-select the object to be cut and then send the WireCut command (with all necessary parameters).
But this is not working and I see the following in the command history:

Select object:
Cannot use these objects. Removing them from selection.
Command: WireCut

I cannot understand why the object is being removed. (Though GetObject.ObjectCount remains 1).
I tried SelBadObjects command and found the object is valid:

Command: SelBadObjects
No objects added to selection.
No bad objects selected.

Preseleting the object to be cut works when commands is issued manually.
So what am I doing wrong in the program?

(GetObject options are set as follows:
go.EnablePreSelect(true, false);
go.SubObjectSelect = false;
go.DeselectAllBeforePostSelect = false;

Can someone please help?

Thank you,

It means that the objects you selected are not valid for the input to the wirecut command. You need to script exactly how you would run the command in Rhino, and each step of selecting objects may need to be ended by sending the Enter command, just like you would press enter to end a multi object selection.

Thanks menno!

I have settled for SelAll.
Tried SelExtrusion (for the object is a solid) but it also works only for the first invocation of WireCut.