Unable to open latest WIP Crash (SOLVED)


Yesterday, I downloaded latest WIP, install, and launch it.
First Pop up window :

Error message: Type Newtonsoft.Json.BsonDataReader has invalid method slot 8 with method none

Try Button, always returns the same windows
Cancel Button open the next error windows:

Says Rhino is unable to find licence…

I download update directly from Rhinowebsite, accessing to the file with my R5mac Licence number.
Rhino5 is still perfectly working across WIP.
I uninstall WIP, load it again, still the same error.
I am unable to access to menu for confirming my licence to WIP

Let me know your advices to solve this problem…

Thank you

Same issue here.
I use Rhino6WIP mac since its release and always updated when the app suggested me to.

  • Since the latest update, rhino kept crashing right after the splash screen.
    (I did submit a system crash report once.)

  • Then I downloaded the latest installer and copied the app to the application folder, overwriting the exsisting app. Since then, I see the same “Newtonsoft.Json…” warning that won’t go away when you click “retry”.
    Clicking on “cancel” we give the “No license found” popup.

At the moment I am unable to launch Rhino6WIP.


Someone has an idea to solve this licence recognition problem?
Is there a way to manually enter the V6WIP licence, because it is crashing without the opportunity to enter a licence number.
I uninstall it again and try to remove everything which appears to be from V6 on my computer, install it again and same problem…

Thank you

The same.

Hi All-

This sounds annoying. I’m struggling to reproduce this here and I can’t. Please help me see what I’m doing wrong.

(I made the presumption that Rhino had not been licensed before, so I deleted all traces of my license…I don’t know if that is the case here or not for each of you, but I thought I should mention it).

  1. Launched the RhinoWIP 6.13.19016.16066.
  2. Rhino immediately tells me I need a license…

  1. I clicked Enter your license key
  2. I entered my license key provided by the email by @brian
  3. On the next screen, I clicked Use Only on This Computer

  1. Rhino asks me to register, which I do…and Rhino launches.

I expect I’m doing something completely different from all of you.

Do you even make it to step 2 above? Or were you already licensed and Rhino just started crashing?



I am unsure as to why this is happening, but following the instructions below should solve it. It if happens after you’ve tried the steps below, PLEASE LET ME KNOW!

Hi Dan,

Thank you for your time trying to solve our problem.
For me, Rhino 6 was already licenced, before with previous WIP ( I install every update…almost each week actually).
I have working across it Rhino 5, with valid licence (used for downlaoding WIP)

The only thing i did differently, was to do no have updated when Rhino startup asked it, but using file>check for updates, then download install file from mcneel website

After install, no opportunity to enter my licence, immediatly, json error, then licence missing, and stop…
Uninstalling, maybe there is still remaining parts from previous licence, but i’m not mac technician, so i only put app in trash, looked for rhino 6.0 folder and remove them, empty trash, reboot redownload and reinstall without success…

newton json seem to be the problem…

Hello Andres,

I follow exactly your post, remove cloudzoo and restart it again… nothing changes.

I send to you PM cloudzoo txt

One more test without success
I Retrieve old WIP (downloaded files of my computer), but an expired one, install it, be prompted that version was expire. I was happy because it do not crash immediately, juste asked me to download new version from website before closing…and again, install last WIP on existing old one, asked to write on it, I say yes, and again crash as previously…

My first idea was to reinstall previous (not an expire WIP) but the Mcneel link only redirect on last WIP file…

Is there a link to download

because I only have possibility to build-6-13-19016-12066/77402

Thank you

@antoine it has been reported that the problem is the Iris plugin. Do you have this plugin installed? If so, please try removing it and Rhino should launch. We are looking for a permanent solution so this doesn’t happen again.

Hi @Andres thank you very much, it works perfectly.
I looked for Irisplugin I used few months ago, installed into Rhino5 folder, delete folders and solve the problem.

But for your information something strange was the multiples duplicate folders aside “real” iris folder.
Each folder had same files thant Iris, but with serial number folder name…

Maybe it could help

Thank you again

Best regards

The latest RhinoWIP should load Newtonsoft.Json.dll early and not crash, even if other plugins or Grasshopper components (like Iris) are loaded. Please give it a try.

Thanks again for reporting this.

Thanks a ton, Dan!
For me, the issue is solved and RhinoWIP is back on my mac :slight_smile:

I’m getting the same “License not found” error on startup with a clean install with no plugins–about half the time it’s accompanied by a crash (I have the log file). When compared to my laptop (which runs the WIP w/o an issue and has had a couple previous WIPs installed), both the “/Library/Application Support/” and “/Library/Application Support” have different folders and folder structures inside the McNeel folder.

Did the recent WIP change the Library files, or do I need to blow-out everything in the McNeel folder and reinstall both 5 & 6?

Our recent update changed the order of loading the conflicted Newtonsoft.Json.dll that was causing the error reported above: we now load our version of that library first. I suspect, if you have updated to the latest RhinoWIP, you are experiencing a different problem.

Rhino 5 for Mac should not be effected by this change at all.

Rhino 5 is working fine. I just deleted both 5 and 6WIP + the Library/App Support/McNeel folders in both the “Mac HD/Library” and “user/Library”, and then and did clean installs of both versions.

Same result. 5 will run fine again, but 6WIP will pop up the “License Not Found” dialog at startup: 12%20PM

Is there any way to manually enter my license?

The RhinoWIP stores its license file here:

/Library/Application Support/McNeel/Rhinoceros/6.0/License Manager/Licenses

In order for a license to be used across all accounts on a particular machine, we store it in the global library. In order to write to the Licenses folder, we need to “elevate” and twiddle the permissions on that folder (this is the one-time request for your password when first launching Rhino for Mac).

It is possible that you might not have actually deleted this folder. I would suggest you double-check. If this folder is not present, the next time you launch Rhino for Mac, it will ask you for your password again so it can create the folder and write the license information there.

Does that help?

So the 6WIP installer isn’t creating a “6.0” folder in the McNeel folder.

I deleted everything in there, emptied the trash, and rebooted. When I started up Rhino 5, it re-created both the Rhinoceros folder and License Manager sub-folder. When I started the 6WIP, it only created a “registry” folder inside the Rhinoceros one–that happened right before the dialog popped up:

Interesting. Thanks for testing that.

Are you logged into an Administrator account? (System Preferences > Users & Groups)