Unable to merge/join surfaces even though they seem close enough

Hi, I’ve been trying to merge the surfaces for my model so that I can offset everything consistently as well as prep the file for 3d printing. The issue I have now it that the surfaces are unable to join or I consistently get the “edges are too far” error, even after adjusting my tolerance and following instructions from this forum: Edges too far apart to merge. Tried all that I know and more!

The reason why I do not want to offset these parts separately is due to the fact that the ends will not blend very well together.

I have also tried rebuilding some surfaces but to no avail.
To be cleaned.3dm (2.1 MB)

Hi Lester - Join works, MergeSrf does not, and will not with these objects but probably does not need to - joining should be all you need I would think - why are you looking at merging?



Hi Pascal,

Merging actually creates a smoother surface(first image was using join and second with merge) image

However, the merging is more specific to this part (in the images). The other issue is that this part is unable to join with the base plate and the outer bowl.

This part is where the main issue is at. It is now made up of 4 separate surfaces, 2 of which I have managed to join.

Hi Lester-

This is not generally true - your first image shows a quite coarse render mesh that is flat shaded - not a good way to judge - your merged surfaces in the file you posted show a noticeable wiggle (in Zebra) there where you merged them:

I’d think about greatly simplifying your surfaces, and using MatchSrf to clean up where needed. The input curves are missing, so I can’t be of much help there at the moment.

In any case - merging requires untrimmed surfaces and edges that meet up along their length - if you untrim your surfaces you’ll see that they are different in length along the common edges - if you fix that and merge, it should work, and then you can trim the result.


Hi Pascal,

Is there a specific way of simplifiying my surfaces? I tried rebuilding them but it doesnt work.
Also, it needs to be a complete single surface, instead of polysurface because of the grasshopper script we’re going to run on it.